summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark E.A2016-06-23 21:30:39 +0200
committerMark E.A2016-06-23 21:30:39 +0200
commitd13ab0eb7d3688a3099f021f56d9a4a41dac07fe (patch)
tree5140c55b489a6913bbe676805a0734714a149c9f
downloadaur-d13ab0eb7d3688a3099f021f56d9a4a41dac07fe.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9162f47f7007
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Thu Jun 23 19:28:31 UTC 2016
+pkgbase = python-marisa-trie
+ pkgdesc = Static memory-efficient & fast Trie-like structures for Python (based on marisa-trie C++ library)
+ pkgver = 0.7.2
+ pkgrel = 1
+ url = https://github.com/kmike/marisa-trie
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = python
+ source = https://github.com/kmike/marisa-trie/archive/0.7.2.tar.gz
+ sha256sums = 5a5ca6a032fe924097f87439130f013dfb2682e597f4d5414bb87cfe49bc715e
+
+pkgname = python-marisa-trie
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ccfba71415a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Mark E.A. <evalapply ``dot'' aur ``at'' airmail ``dot'' cc>
+
+pkgname=python-marisa-trie
+_pyname=marisa-trie
+pkgver=0.7.2
+pkgrel=1
+pkgdesc='Static memory-efficient & fast Trie-like structures for Python (based on marisa-trie C++ library)'
+arch=('i686' 'x86_64')
+url='https://github.com/kmike/marisa-trie'
+license=('MIT')
+depends=('python')
+makedepends=()
+optdepends=()
+source=("https://github.com/kmike/${_pyname}/archive/${pkgver}.tar.gz")
+sha256sums=('5a5ca6a032fe924097f87439130f013dfb2682e597f4d5414bb87cfe49bc715e')
+
+build() {
+ cd "$_pyname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_pyname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}