summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYufan You2020-09-05 16:22:43 +0800
committerYufan You2020-09-05 16:22:43 +0800
commit07f8d5d2ec54426c51fabeefe48c1dfa4d474012 (patch)
tree4259cd67537bbed8cf6327bf65a506e7d7c7f060
downloadaur-07f8d5d2ec54426c51fabeefe48c1dfa4d474012.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD34
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e085a8c8676
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python-mathlibtools
+ pkgdesc = This package contains leanproject, a supporting tool for Lean mathlib
+ pkgver = 0.0.10
+ pkgrel = 1
+ url = https://github.com/leanprover-community/mathlib-tools
+ arch = any
+ license = Apache
+ depends = python-toml
+ depends = python-pygithub
+ depends = python-certifi
+ depends = python-gitpython
+ depends = python-requests
+ depends = python-click
+ depends = python-tqdm
+ depends = python-networkx
+ depends = python-pydot
+ depends = python-yaml
+ optdepends = lean-community
+ source = https://files.pythonhosted.org/packages/fc/21/6b871d00cea09d2e94b9014997b9df160b003f53b4fb89e1cd93ff6f2990/mathlibtools-0.0.10.tar.gz
+ sha256sums = 66e86498d4f06cfa83270e907dac5bfba07960884e99c2306410caaedf42e034
+
+pkgname = python-mathlibtools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8007d3f2c036
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Yufan You <ouuansteve at gmail>
+
+pkgname=python-mathlibtools
+pkgver=0.0.10
+pkgrel=1
+pkgdesc='This package contains leanproject, a supporting tool for Lean mathlib'
+arch=('any')
+url="https://github.com/leanprover-community/mathlib-tools"
+license=('Apache')
+depends=(
+ 'python-toml'
+ 'python-pygithub'
+ 'python-certifi'
+ 'python-gitpython'
+ 'python-requests'
+ 'python-click'
+ 'python-tqdm'
+ 'python-networkx'
+ 'python-pydot'
+ 'python-yaml'
+)
+optdepends=('lean-community')
+source=("https://files.pythonhosted.org/packages/fc/21/6b871d00cea09d2e94b9014997b9df160b003f53b4fb89e1cd93ff6f2990/mathlibtools-$pkgver.tar.gz")
+sha256sums=(66e86498d4f06cfa83270e907dac5bfba07960884e99c2306410caaedf42e034)
+
+build() {
+ cd "mathlibtools-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "mathlibtools-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}