summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYufan You2020-09-10 12:48:57 +0000
committerYufan You2020-09-10 12:48:57 +0000
commitf23e72afa6e4ceb7d7283ded9f00a6b52590abe9 (patch)
tree024cac4b956c3532ff8c49899d4261d698cc0e18
parent0520d115850a2345b6bfede995a7769a9f0df1c4 (diff)
downloadaur-f23e72afa6e4ceb7d7283ded9f00a6b52590abe9.tar.gz
Update from GitHub Actions: python-mathlibtools: Update the source URL
https://github.com/ouuan/AUR-packages/actions/runs/248040453
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c945611e26a..36e4eb2c3994 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,7 +17,7 @@ pkgbase = python-mathlibtools
depends = python-pydot
depends = python-yaml
optdepends = lean-community
- source = https://files.pythonhosted.org/packages/fc/21/6b871d00cea09d2e94b9014997b9df160b003f53b4fb89e1cd93ff6f2990/mathlibtools-0.0.10.tar.gz
+ source = https://pypi.io/packages/source/m/mathlibtools/mathlibtools-0.0.10.tar.gz
sha256sums = 66e86498d4f06cfa83270e907dac5bfba07960884e99c2306410caaedf42e034
pkgname = python-mathlibtools
diff --git a/PKGBUILD b/PKGBUILD
index 65d3de22fcc1..0cceffefefb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Yufan You <ouuansteve at gmail>
-pkgname=python-mathlibtools
+_pkgname=mathlibtools
+pkgname=python-$_pkgname
pkgver=0.0.10
pkgrel=2
pkgdesc='This package contains leanproject, a supporting tool for Lean mathlib'
@@ -21,15 +22,15 @@ depends=(
)
makedepends=('python-setuptools')
optdepends=('lean-community')
-source=("https://files.pythonhosted.org/packages/fc/21/6b871d00cea09d2e94b9014997b9df160b003f53b4fb89e1cd93ff6f2990/mathlibtools-$pkgver.tar.gz")
+source=("https://pypi.io/packages/source/m/$_pkgname/$_pkgname-$pkgver.tar.gz")
sha256sums=(66e86498d4f06cfa83270e907dac5bfba07960884e99c2306410caaedf42e034)
build() {
- cd "mathlibtools-$pkgver"
+ cd "$_pkgname-$pkgver"
python setup.py build
}
package() {
- cd "mathlibtools-$pkgver"
+ cd "$_pkgname-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}