summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancisco Pina Martins2015-06-09 14:01:30 +0100
committerFrancisco Pina Martins2015-06-09 14:01:30 +0100
commit01dce190bb0b315dbbd718594fb731de9a7bd0e5 (patch)
tree292eaf18e39684b5b7912e11d1492981b68f47ac
downloadaur-01dce190bb0b315dbbd718594fb731de9a7bd0e5.tar.gz
Initial import.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..abdd72c52c54
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-matplotlib-venn
+ pkgdesc = Functions for plotting area-proportional two- and three-way Venn diagrams in matplotlib
+ pkgver = 0.11
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/matplotlib-venn
+ arch = any
+ license = MIT
+ depends = python-numpy
+ depends = python-matplotlib
+ depends = python-scipy
+ source = https://pypi.python.org/packages/source/m/matplotlib-venn/matplotlib-venn-0.11.zip
+ md5sums = 9100680061567a5bb955b5293bcadf9e
+
+pkgname = python-matplotlib-venn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a764c43b8aa0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Stunts <f.pinamartins@gmail.com>
+
+pkgname=python-matplotlib-venn
+_upstream_pkgname=matplotlib-venn
+pkgver=0.11
+pkgrel=1
+pkgdesc="Functions for plotting area-proportional two- and three-way Venn diagrams in matplotlib"
+arch=('any')
+url="https://pypi.python.org/pypi/matplotlib-venn"
+license=('MIT')
+depends=('python-numpy' 'python-matplotlib' 'python-scipy')
+source=(https://pypi.python.org/packages/source/m/matplotlib-venn/${_upstream_pkgname}-${pkgver}.zip)
+md5sums=('9100680061567a5bb955b5293bcadf9e')
+
+build() {
+ cd "${srcdir}/${_upstream_pkgname}-${pkgver}"
+ yes | python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_upstream_pkgname}-${pkgver}"
+ yes | python setup.py install --root="${pkgdir}"
+}