summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Neumann2023-05-04 10:20:48 +0200
committerRichard Neumann2023-05-04 10:20:48 +0200
commit4bda8d769613ca7418b1064d21b56cd05a3cce46 (patch)
tree96db8b9b54d1f143f321b92ae1536687112d544f
parentac8b9457845b9a9403d068d6f7d462db89152edb (diff)
downloadaur-python-mcipc.tar.gz
Migrate to python-build and python-installer
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2dcecb1b7a29..b60bd7517b18 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = python-mcipc
pkgdesc = Python 3 library and scripts for the RCON and Query protocol
pkgver = 2.4.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/coNQP/mcipc
arch = any
license = GPLv3
makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools-scm
+ makedepends = python-wheel
depends = python
depends = python-setuptools
depends = python-rcon>=2.3.4
diff --git a/PKGBUILD b/PKGBUILD
index 12c34fc72b50..71c7f91c9bc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,22 @@
_pkgbase='mcipc'
pkgname="python-${_pkgbase}"
pkgver=2.4.2
-pkgrel=1
+pkgrel=2
pkgdesc='Python 3 library and scripts for the RCON and Query protocol'
arch=('any')
url="https://github.com/coNQP/${_pkgbase}"
license=('GPLv3')
depends=('python' 'python-setuptools' 'python-rcon>=2.3.4')
-makedepends=('git' 'python-setuptools-scm')
+makedepends=('git' 'python-build' 'python-installer' 'python-setuptools-scm' 'python-wheel')
source=("${_pkgbase}::git+${url}.git#tag=${pkgver}")
md5sums=('SKIP')
build() {
cd "${srcdir}/${_pkgbase}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${srcdir}/${_pkgbase}"
- python setup.py install --root "${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}