summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Neumann2019-05-27 10:17:33 +0200
committerRichard Neumann2019-05-27 10:17:33 +0200
commit54437a49a7c1d566583e912843a6ec348596d343 (patch)
treec3fe9cc73bc239dfd6407c5aeb5312a1aea90eac
downloadaur-54437a49a7c1d566583e912843a6ec348596d343.tar.gz
Init.
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f04432a3dfd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mcipc
+ pkgdesc = Python 3 library and scripts for the RCON and Query protocol
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/coNQP/mcipc
+ arch = any
+ license = GPLv3
+ makedepends = git
+ makedepends = python
+ makedepends = python-setuptools
+ makedepends = python-setuptools-git
+ depends = python
+ depends = python-docopt
+ source = mcipc::git+https://github.com/coNQP/mcipc.git#tag=1.0.2
+ md5sums = SKIP
+
+pkgname = mcipc
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e22caf24a73f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz*
+mcipc/
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b95fea6b1596
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Richard Neumann aka. schard <mail at richard dash neumann period de>
+
+pkgname='mcipc'
+pkgver=1.0.2
+pkgrel=1
+pkgdesc='Python 3 library and scripts for the RCON and Query protocol'
+arch=('any')
+url="https://github.com/coNQP/${pkgname}"
+license=('GPLv3')
+depends=('python' 'python-docopt')
+makedepends=('git' 'python' 'python-setuptools' 'python-setuptools-git')
+source=("${pkgname}::git+${url}.git#tag=${pkgver}")
+md5sums=('SKIP')
+
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py install --root "${pkgdir}" --optimize=1
+}