summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranco Masotti2018-03-25 18:11:48 +0200
committerFranco Masotti2018-03-25 18:11:48 +0200
commit6d41ec87a1ebfa089a76bfc3445709dd0bd91895 (patch)
treecde19088c982601ee6769b2f4f938f83bc8b11af
downloadaur-6d41ec87a1ebfa089a76bfc3445709dd0bd91895.tar.gz
Initial commit.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..923a09134407
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-md_toc
+ pkgdesc = Automatically generate a compliant table of contents for a markdown file to improve document readability
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://github.com/frnmst/md-toc
+ arch = any
+ license = GPL3
+ depends = python
+ depends = python-fpyutils
+ depends = python-setuptools
+ options = !emptydirs
+ source = python-md_toc.tar.gz::https://github.com/frnmst/md-toc/archive/2.0.1.tar.gz
+ sha256sums = 89dfefe0e9e7d91821a52ec14fae5a7a5e7a0e9e151b7458f5526c25714345c7
+
+pkgname = python-md_toc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7eb2e287bea4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Franco Masotti <franco dot masotti at student dot unife dot it>
+# Contributor: Franco Masotti <franco dot masotti at student dot unife dot it>
+pkgname=python-md_toc
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Automatically generate a compliant table of contents for a markdown file to improve document readability"
+arch=('any')
+url="https://github.com/frnmst/md-toc"
+license=('GPL3')
+depends=('python'
+ 'python-fpyutils'
+ 'python-setuptools')
+options=(!emptydirs)
+source=("${pkgname}.tar.gz::https://github.com/frnmst/md-toc/archive/${pkgver}.tar.gz")
+sha256sums=('89dfefe0e9e7d91821a52ec14fae5a7a5e7a0e9e151b7458f5526c25714345c7')
+
+check() {
+ cd "${srcdir}"/md-toc-"${pkgver}"
+ python setup.py test
+}
+
+package() {
+ cd "${srcdir}"/md-toc-"${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}
+
+