summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHector Martinez-Seara2024-05-03 14:59:08 +0200
committerHector Martinez-Seara2024-05-03 14:59:08 +0200
commit84844e2f3aa896be348567632d5b0eb63283473d (patch)
treef95413058aab520ddfaaf3c16b44dc81db2108b5
parentfe8d18e94ab4c9d5ea906485146ee1c4d4f4248e (diff)
downloadaur-84844e2f3aa896be348567632d5b0eb63283473d.tar.gz
Updated 2.7.0
-rw-r--r--.SRCINFO10
-rw-r--r--0001-Allow-using-newer-numpy.patch9
-rw-r--r--PKGBUILD12
3 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5d3e6867909..69e0f70b600e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-mdanalysis
pkgdesc = An object-oriented python toolkit to analyze molecular dynamics trajectories generated by CHARMM, Gromacs, NAMD, LAMMPS, or Amber.
- pkgver = 2.6.1
+ pkgver = 2.7.0
pkgrel = 1
url = http://www.mdanalysis.org/
arch = x86_64
@@ -18,13 +18,15 @@ pkgbase = python-mdanalysis
depends = python-biopython
depends = python-fasteners
depends = python-packaging
+ depends = python-build
+ depends = python-installer
optdepends = python-matplotlib: to use all MDAnalysis functions
optdepends = python-joblib: to use all MDAnalysis functions
optdepends = python-netcdf4: to operate on AMBER binary trajectories
optdepends = python-networkx: for analysis of lipid leaflets via MDAnalysis.analysis.leaflet
- source = https://github.com/MDAnalysis/mdanalysis/archive/refs/tags/package-2.6.1.tar.gz
+ source = https://github.com/MDAnalysis/mdanalysis/archive/refs/tags/package-2.7.0.tar.gz
source = 0001-Allow-using-newer-numpy.patch
- sha256sums = cdeeaef733ad0ec8d41a2961c3c445d7de4c8b2a8b6c76ac9321ed820872a3a6
- sha256sums = e4391d3c6a75e8b2a0275ff9799afbfbec2f9897f195ce003fc17e4b9f5ef75e
+ sha256sums = 06dc48170945271c9e52532b896f3e8b622026b7fb3683f5ec49a323b97ce800
+ sha256sums = 0e1633cf4295b70a561ba50f8870e6bad0f96c51fa9cb984bff8333abe24145a
pkgname = python-mdanalysis
diff --git a/0001-Allow-using-newer-numpy.patch b/0001-Allow-using-newer-numpy.patch
index 041567338e04..b2d5226aee50 100644
--- a/0001-Allow-using-newer-numpy.patch
+++ b/0001-Allow-using-newer-numpy.patch
@@ -1,11 +1,12 @@
--- a/pyproject.toml
+++ b/pyproject.toml
-@@ -13,7 +13,7 @@ requires = [
+@@ -13,8 +13,8 @@ requires = [
# on other archs
"numpy==1.22.3; python_version=='3.9' and platform_python_implementation != 'PyPy'",
"numpy==1.22.3; python_version=='3.10' and platform_python_implementation != 'PyPy'",
-- "numpy==1.23.2; python_version=='3.11' and platform_python_implementation != 'PyPy'",
-+ "numpy>=1.23.2; python_version=='3.11' and platform_python_implementation != 'PyPy'",
+ "numpy==1.23.2; python_version=='3.11' and platform_python_implementation != 'PyPy'",
+- "numpy==1.26.0; python_version=='3.12' and platform_python_implementation != 'PyPy'",
++ "numpy>=1.26.0; python_version=='3.12' and platform_python_implementation != 'PyPy'",
# For unreleased versions of Python there is currently no known supported
# NumPy version. In that case we just let it be a bare NumPy install
- "numpy<2.0; python_version>='3.12'",
+ "numpy<2.0; python_version>='3.13'",
diff --git a/PKGBUILD b/PKGBUILD
index 8e63c284cf7c..92150867306d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,23 @@
# Maintainer: Vedran Miletic <vedran AT miletic DOT net>
pkgname=python-mdanalysis
-pkgver=2.6.1
+pkgver=2.7.0
pkgrel=1
pkgdesc="An object-oriented python toolkit to analyze molecular dynamics trajectories generated by CHARMM, Gromacs, NAMD, LAMMPS, or Amber."
url="http://www.mdanalysis.org/"
license=("GPL")
arch=('x86_64')
-depends=('python-numpy' 'cython' 'python-mmtf' 'python-gsd' 'python-tqdm' 'python-griddataformats' 'python-scipy' 'python-biopython' 'python-fasteners' 'python-packaging')
+depends=('python-numpy' 'cython' 'python-mmtf' 'python-gsd' 'python-tqdm' 'python-griddataformats' 'python-scipy' 'python-biopython' 'python-fasteners' 'python-packaging' 'python-build' 'python-installer')
makedepends=("python-build" "python-installer" "python-wheel")
optdepends=('python-matplotlib: to use all MDAnalysis functions'
'python-joblib: to use all MDAnalysis functions'
'python-netcdf4: to operate on AMBER binary trajectories'
'python-networkx: for analysis of lipid leaflets via MDAnalysis.analysis.leaflet')
-source=(https://github.com/MDAnalysis/mdanalysis/archive/refs/tags/package-$pkgver.tar.gz
- 0001-Allow-using-newer-numpy.patch)
-sha256sums=('cdeeaef733ad0ec8d41a2961c3c445d7de4c8b2a8b6c76ac9321ed820872a3a6'
- 'e4391d3c6a75e8b2a0275ff9799afbfbec2f9897f195ce003fc17e4b9f5ef75e')
+ source=(https://github.com/MDAnalysis/mdanalysis/archive/refs/tags/package-$pkgver.tar.gz
+ 0001-Allow-using-newer-numpy.patch)
+sha256sums=('06dc48170945271c9e52532b896f3e8b622026b7fb3683f5ec49a323b97ce800'
+ '0e1633cf4295b70a561ba50f8870e6bad0f96c51fa9cb984bff8333abe24145a')
build() {
cd $srcdir/mdanalysis-package-$pkgver/package