summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjdarnold2015-08-25 11:32:18 -0400
committerjdarnold2015-08-25 11:32:18 -0400
commit3a820cf3f0eed87156a02122c5f81205950e83e0 (patch)
treec75d8cb8bc56ee207695dbbf4c2fd30bc9efb14a
downloadaur-3a820cf3f0eed87156a02122c5f81205950e83e0.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f13efbc167a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-mechanicalsoup
+ pkgdesc = A Python library for automating interaction with websites
+ pkgver = 0.3.1
+ pkgrel = 3
+ url = https://github.com/hickford/MechanicalSoup
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-beautifulsoup4
+ depends = python-requests
+ depends = python-six
+ source = https://github.com/hickford/MechanicalSoup/archive/v0.3.1.tar.gz
+ md5sums = fe5855a6a8b8e07691e29e25e4f0ef0d
+
+pkgname = python-mechanicalsoup
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3c43c356223
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Jonathan Arnold <jdarnold@archlinux.us>
+# Contributor: Zhang Hai <dreaming.in.code.zh@gmail.com>
+
+pkgname=python-mechanicalsoup
+pkgver=0.3.1
+pkgrel=3
+pkgdesc="A Python library for automating interaction with websites"
+arch=('any')
+url="https://github.com/hickford/MechanicalSoup"
+license=('MIT')
+depends=('python-beautifulsoup4' 'python-requests' 'python-six')
+makedepends=('python-setuptools')
+source=("https://github.com/hickford/MechanicalSoup/archive/v${pkgver}.tar.gz")
+md5sums=('fe5855a6a8b8e07691e29e25e4f0ef0d')
+
+package() {
+ cd "${srcdir}/MechanicalSoup-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}