summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjdarnold2015-08-25 11:50:13 -0400
committerjdarnold2015-08-25 11:50:13 -0400
commit6e203bd9d688d8104a7d55e5bfd6f48945c69df9 (patch)
treeaf38ec761707ca853ef2661fad294cd1034ae1ad
parenta8cb24a16cc7bc24559ec57da5c3edd009f11f15 (diff)
downloadaur-6e203bd9d688d8104a7d55e5bfd6f48945c69df9.tar.gz
add special depends for 2 and 3
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD8
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c3e185c78cf..042c87a66f8e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,23 @@
pkgbase = python-mechanicalsoup
pkgdesc = A Python library for automating interaction with websites
pkgver = 0.3.1
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/hickford/MechanicalSoup
arch = any
license = MIT
makedepends = python-setuptools
- depends = python-beautifulsoup4
- depends = python-requests
- depends = python-six
source = https://github.com/hickford/MechanicalSoup/archive/v0.3.1.tar.gz
md5sums = fe5855a6a8b8e07691e29e25e4f0ef0d
pkgname = python2-mechanicalsoup
depends = python2
+ depends = python2-beautifulsoup4
+ depends = python2-requests
+ depends = python2-six
pkgname = python-mechanicalsoup
depends = python
+ depends = python-beautifulsoup4
+ depends = python-requests
+ depends = python-six
diff --git a/PKGBUILD b/PKGBUILD
index be9d4d3f73e5..34b2f06fbd0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,12 @@ _pkgname="MechanicalSoup"
pkgbase=python-mechanicalsoup
pkgname=('python2-mechanicalsoup' 'python-mechanicalsoup')
pkgver=0.3.1
-pkgrel=4
+pkgrel=5
pkgdesc="A Python library for automating interaction with websites"
arch=('any')
url="https://github.com/hickford/MechanicalSoup"
license=('MIT')
-depends=('python-beautifulsoup4' 'python-requests' 'python-six')
+depends=( )
makedepends=('python-setuptools')
source=("https://github.com/hickford/MechanicalSoup/archive/v${pkgver}.tar.gz")
md5sums=('fe5855a6a8b8e07691e29e25e4f0ef0d')
@@ -29,13 +29,13 @@ check() {
}
package_python-mechanicalsoup() {
- depends=('python')
+ depends=('python' 'python-beautifulsoup4' 'python-requests' 'python-six')
cd $srcdir/${_pkgname}-$pkgver
python3 setup.py install --root "${pkgdir}" --optimize=1
}
package_python2-mechanicalsoup() {
- depends=('python2')
+ depends=('python2' 'python2-beautifulsoup4' 'python2-requests' 'python2-six')
cd $srcdir/${_pkgname}2-$pkgver
python2 setup.py install --root "${pkgdir}" --optimize=1
}