summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew DeVault2018-05-05 17:32:46 -0400
committerDrew DeVault2018-05-05 17:32:46 -0400
commit52a88b504c4fa5d947fbb98b0f53987ce29be40d (patch)
treef217caa52f2f421d4fba6ce1fa42f5bf43a6d998
downloadaur-52a88b504c4fa5d947fbb98b0f53987ce29be40d.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..14bf055b9ffd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-medium
+ pkgdesc = A Python wrapper for the Medium API
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/Medium/medium-sdk-python
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-requests
+ source = https://files.pythonhosted.org/packages/source/m/medium/medium-0.3.0.tar.gz
+ sha256sums = 0712a3e6c99467c97a46b0c7ef6ba0dec079018fc40f6093dc98d95c05ece7fd
+
+pkgname = python-medium
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0a2223f3641d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e73fa9937223
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+_name=medium
+pkgname="python-${_name}"
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="A Python wrapper for the Medium API"
+url="https://github.com/Medium/medium-sdk-python"
+arch=("any")
+license=("MIT")
+depends=("python" "python-requests")
+makedepends=("python-setuptools")
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('0712a3e6c99467c97a46b0c7ef6ba0dec079018fc40f6093dc98d95c05ece7fd')
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}