summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2018-02-19 22:23:26 +0100
committerNarrat2018-02-19 22:23:26 +0100
commit45dd84ef99155ad4ccbba5b2fe5734bace5b81bd (patch)
tree2fe06f5304af55c4fce1d8862a29ff48f3b81633
parent3ae666a83e132658b7044f178424d21a330280f7 (diff)
downloadaur-45dd84ef99155ad4ccbba5b2fe5734bace5b81bd.tar.gz
mem_top: Update to 0.1.7
And switched download URL. Instead of the hassle with a wheel package, clone the Repo at the release commit and do it the usual way
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 511dec88c3de..a1e47a7e865e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = python-mem_top
pkgdesc = Shows top suspects for memory leaks in your Python program
- pkgver = 0.1.6
+ pkgver = 0.1.7
pkgrel = 1
url = https://pypi.python.org/pypi/mem_top
arch = any
license = MIT
depends = python
- source = https://pypi.io/packages/source/m/mem_top/mem_top-0.1.6.tar.gz
- md5sums = 797f791971b2ad8cebdb1ba4f5f650e5
+ source = git+https://github.com/denis-ryzhkov/mem_top#commit=037c1281
+ md5sums = SKIP
pkgname = python-mem_top
diff --git a/PKGBUILD b/PKGBUILD
index 4205606c6d5d..3a171dd22141 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Lex Black <autumn-wind at web dot de>
-_pkgname=mem_top
+_name=mem_top
pkgname=python-mem_top
-pkgver=0.1.6
+pkgver=0.1.7
pkgrel=1
arch=('any')
pkgdesc="Shows top suspects for memory leaks in your Python program"
url="https://pypi.python.org/pypi/mem_top"
license=("MIT")
depends=('python')
-source=(https://pypi.io/packages/source/m/$_pkgname/$_pkgname-$pkgver.tar.gz)
-md5sums=('797f791971b2ad8cebdb1ba4f5f650e5')
+source=(git+https://github.com/denis-ryzhkov/mem_top#commit=037c1281)
+md5sums=('SKIP')
package() {
- cd ${_pkgname}-${pkgver}
+ cd ${_name}
python setup.py install --prefix=/usr --root=${pkgdir} --optimize=1
}