summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2020-03-10 14:14:47 +0200
committerChristoph Fink2020-03-10 14:14:47 +0200
commite4ea120d1f7ac091167bb6fbc2e4d7511418dd80 (patch)
treeec370d39cc22d1220e1b9061a432cfff79636bf9
downloadaur-e4ea120d1f7ac091167bb6fbc2e4d7511418dd80.tar.gz
v0.15.2-0
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE7
-rw-r--r--PKGBUILD40
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5308d1da70df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-messytables
+ pkgdesc = Parse messy tabular data in various formats
+ pkgver = 0.15.2
+ pkgrel = 0
+ url = https://messytables.readthedocs.io/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/m/messytables/messytables-0.15.2.tar.gz
+ source = LICENSE
+ sha256sums = 227a5aac364919a7d3faa6ce04027fcbd03e041efcd3d57fabb1d1067591a2cd
+ sha256sums = ec2a81b15d8ddae532b9e5b9bd325130758a77568869294a1450e0c11c5f24a6
+
+pkgname = python-messytables
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..1b33eac5450b
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,7 @@
+Copyright 2019 Open Knowledge Labs
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d33001a33a60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: peippo <christoph+aur@christophfink.com>
+
+pkgname="python-messytables"
+_name=${pkgname#python-}
+pkgdesc="Parse messy tabular data in various formats"
+url="https://messytables.readthedocs.io/"
+
+pkgver=0.15.2
+pkgrel=0
+
+arch=("any")
+license=("MIT")
+
+makedepends=(
+ "python-setuptools"
+)
+depends=(
+ "python"
+)
+
+source=(
+ "https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
+ "LICENSE"
+)
+sha256sums=(
+ "227a5aac364919a7d3faa6ce04027fcbd03e041efcd3d57fabb1d1067591a2cd"
+ "ec2a81b15d8ddae532b9e5b9bd325130758a77568869294a1450e0c11c5f24a6"
+)
+
+build() {
+ cd "${srcdir}"/${_name}-${pkgver}
+ python setup.py build
+}
+
+package() {
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}