summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikita Volodin [Никита Володин]2015-06-22 23:58:55 -0300
committerNikita Volodin [Никита Володин]2015-06-22 23:58:55 -0300
commitdb7d8b08e3a800d98d4a7e66cb3d7af800277637 (patch)
treefb0fff4a2db402f987228129ce9a1ede54b7af6f
downloadaur-db7d8b08e3a800d98d4a7e66cb3d7af800277637.tar.gz
feat(python-meteor-ejson): initial import
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD22
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c426b743e566
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-meteor-ejson
+ pkgdesc = Encoder and Decoder for Extended JSON (EJSON) as used in Meteor and DDP.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/lyschoening/meteor-ejson-python
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-six
+ source = https://pypi.python.org/packages/source/m/meteor-ejson/meteor-ejson-1.0.0.tar.gz
+ md5sums = 90952e08f858e936ea6703e503c6f01c
+
+pkgname = python-meteor-ejson
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8e7aa272f6d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*~
+
+pkg/
+src/
+
+*.tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff248762dbc7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+#Automatically generated by pip2arch on 2015-06-22
+
+pkgname=python-meteor-ejson
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Encoder and Decoder for Extended JSON (EJSON) as used in Meteor and DDP."
+url="https://github.com/lyschoening/meteor-ejson-python"
+depends=('python' 'python-six')
+license=('MIT')
+arch=('any')
+source=("https://pypi.python.org/packages/source/m/meteor-ejson/meteor-ejson-$pkgver.tar.gz")
+md5sums=('90952e08f858e936ea6703e503c6f01c')
+
+build() {
+ cd "$srcdir/meteor-ejson-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/meteor-ejson-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}