summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOSAMC2023-07-21 21:23:50 +0000
committerChristopher Arndt2023-07-21 21:23:50 +0000
commit19b9ea269daf76160034f5c6905f593cad0042ca (patch)
tree9b85bcac09c760bfea1bbdaf9a6cbcb6d9735684
parent5de315931776a5aa5a7588a281494cdb95b5d8b3 (diff)
downloadaur-19b9ea269daf76160034f5c6905f593cad0042ca.tar.gz
feat: update package python-mido to version 1.3.0-1 (#255)
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD14
2 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e42dc7d3b26b..6172a371b69e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,21 @@
pkgbase = python-mido
pkgdesc = A Python library for working with MIDI messages and ports
- pkgver = 1.2.10
- pkgrel = 4
+ pkgver = 1.3.0
+ pkgrel = 1
url = https://mido.readthedocs.io/
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-setuptools-scm
+ makedepends = python-wheel
+ depends = python-importlib-metadata
+ depends = python-packaging
depends = python-rtmidi
optdepends = portmidi: for PortMidi support
optdepends = python-pygame: for PortMidi support
- source = https://files.pythonhosted.org/packages/source/m/mido/mido-1.2.10.tar.gz
- sha256sums = 17b38a8e4594497b850ec6e78b848eac3661706bfc49d484a36d91335a373499
+ source = https://files.pythonhosted.org/packages/source/m/mido/mido-1.3.0.tar.gz
+ sha256sums = 84282e3ace34bca3f984220db2dbcb98245cfeafb854260c02e000750dca86aa
pkgname = python-mido
diff --git a/PKGBUILD b/PKGBUILD
index 6e5416811ee0..9df7efeb2eb2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,29 @@
_name='mido'
pkgname=python-$_name
-pkgver=1.2.10
-pkgrel=4
+pkgver=1.3.0
+pkgrel=1
pkgdesc='A Python library for working with MIDI messages and ports'
url='https://mido.readthedocs.io/'
arch=(any)
-depends=(python-rtmidi)
-makedepends=(python-setuptools)
+depends=(python-importlib-metadata python-packaging python-rtmidi)
+makedepends=(python-build python-installer python-setuptools python-setuptools-scm python-wheel)
optdepends=(
'portmidi: for PortMidi support'
'python-pygame: for PortMidi support'
)
license=(MIT)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('17b38a8e4594497b850ec6e78b848eac3661706bfc49d484a36d91335a373499')
+sha256sums=('84282e3ace34bca3f984220db2dbcb98245cfeafb854260c02e000750dca86aa')
build() {
cd $_name-$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd $_name-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
# license
install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
}