summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2020-03-11 13:24:24 +0100
committerAlexander F. Rødseth2020-03-11 13:24:24 +0100
commitf8859c53e6862dfb3d9ad61a70ac1b5e0dc36984 (patch)
tree8797e6318a792f9d92ffa6b28f95218ceecd7745
downloadaur-f8859c53e6862dfb3d9ad61a70ac1b5e0dc36984.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..91bbc025b051
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-minitree
+ pkgdesc = Log mouse movement
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://github.com/xyproto/minitree
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ source = git+https://github.com/xyproto/minitree#commit=cc5e698c7a6a4c1e2cc9dfcb7ed691b79f3c6ab9
+ md5sums = SKIP
+
+pkgname = python-minitree
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..790058967b19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=python-minitree
+pkgver=0.4.1
+pkgrel=1
+pkgdesc='Log mouse movement'
+arch=(any)
+url='https://github.com/xyproto/minitree'
+license=(MIT)
+depends=(python)
+makedepends=(git python-setuptools)
+source=("git+$url#commit=cc5e698c7a6a4c1e2cc9dfcb7ed691b79f3c6ab9") # tag: 0.4.1
+md5sums=('SKIP')
+
+build() {
+ cd minitree
+ python setup.py build
+}
+
+package() {
+ cd minitree
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# getver: github.com/xyproto/minitree
+# vim: ts=2 sw=2 et: