summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicholas Tomlinson2015-12-14 00:36:46 +0000
committerNicholas Tomlinson2015-12-14 00:36:46 +0000
commit09fbefba5070b807a0a60f829564809a768a4951 (patch)
tree764a20bf2b74d38c5ede99396f73bf4a4e1185cb
downloadaur-09fbefba5070b807a0a60f829564809a768a4951.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bdfad788c16b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-miniupnpc
+ pkgdesc = Repack of the original miniupnp project to facilitate install via PyPi
+ pkgver = 1.9
+ pkgrel = 1
+ url = https://github.com/chenhouwu/miniupnpc
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = python-setuptools
+ depends = python
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/m/miniupnpc/miniupnpc-1.9.tar.gz
+ md5sums = 396f0e9a694582e422d2f140ae9781d2
+ sha256sums = 498b35c5443e8de566f3a4de4bceae28fbf6e08ed59afb5ffd516d0bb718bca6
+
+pkgname = python-miniupnpc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2578d75426eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Techmeology <techmeology@techmeology.co.uk>
+# Based on python2-miniupnpc AUR package
+
+pkgname=python-miniupnpc
+pkgver=1.9
+pkgrel=1
+pkgdesc="Repack of the original miniupnp project to facilitate install via PyPi"
+arch=('i686' 'x86_64')
+depends=('python')
+makedepends=('python-setuptools')
+url="https://github.com/chenhouwu/miniupnpc"
+license=('custom')
+options=(!emptydirs)
+source=(https://pypi.python.org/packages/source/m/${pkgname#python-}/${pkgname#python-}-$pkgver.tar.gz)
+md5sums=('396f0e9a694582e422d2f140ae9781d2')
+sha256sums=('498b35c5443e8de566f3a4de4bceae28fbf6e08ed59afb5ffd516d0bb718bca6')
+
+prepare(){
+ cd $srcdir/${pkgname#python-}-$pkgver
+
+ msg 'Fixing Python version...'
+}
+
+build() {
+ cd $srcdir/${pkgname#python-}-$pkgver
+
+ msg 'Building...'
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/${pkgname#python-}-$pkgver
+
+ msg 'Installing license...'
+ install -Dm 644 LICENSE $pkgdir/usr/share/licenses/python-miniupnpc/LICENSE
+
+ msg 'Installing...'
+ python setup.py install --root="$pkgdir" --optimize=1
+}