summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkewl fft2018-02-12 07:31:31 +0000
committerkewl fft2018-02-12 07:31:31 +0000
commitf967a1f17f3168a643198eafb514bccfa67435d9 (patch)
tree7ab3454123e35679cfb515f4fda5857535b5e8cb
parent6d3655948f6136766881d697bf82c432e1a225da (diff)
downloadaur-f967a1f17f3168a643198eafb514bccfa67435d9.tar.gz
new base package python2/3
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD31
2 files changed, 18 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d690b4fb65e..f3b8a060f982 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,22 +3,19 @@ pkgbase = python-miniupnpc
pkgver = 2.0.20180203
pkgrel = 3
url = http://miniupnp.free.fr
- arch = i686
arch = x86_64
- license = custom
+ license = BSD
makedepends = python
makedepends = python-setuptools
makedepends = python2
makedepends = python2-setuptools
- options = !emptydirs
+ makedepends = sh
source = http://miniupnp.free.fr/files/miniupnpc-2.0.20180203.tar.gz
md5sums = 48fd9c899f77e898c74d2166590da076
pkgname = python-miniupnpc
depends = python
- conflicts = python2-miniupnpc
pkgname = python2-miniupnpc
depends = python2
- conflicts = python-miniupnpc
diff --git a/PKGBUILD b/PKGBUILD
index 48a8bf6c9c8c..fff1f7a4e6da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,47 @@
-# Maintainer: Techmeology <techmeology@techmeology.co.uk>
# Maintainer: Kewl <xrjy@nygb.rh.bet(rot13)>
+# Contributor: Techmeology <techmeology@techmeology.co.uk>
pkgbase=python-miniupnpc
-pkgname=(python-miniupnpc python2-miniupnpc)
+pkgname=('python-miniupnpc' 'python2-miniupnpc')
pkgver=2.0.20180203
pkgrel=3
pkgdesc="A small UPnP client library/tool to access Internet Gateway Devices"
-arch=('i686' 'x86_64')
-makedepends=('python' 'python-setuptools' 'python2' 'python2-setuptools')
+arch=('x86_64')
+makedepends=('python' 'python-setuptools' 'python2' 'python2-setuptools' 'sh')
url="http://miniupnp.free.fr"
-license=('custom')
-options=(!emptydirs)
-source=(http://miniupnp.free.fr/files/${pkgbase#python-}-${pkgver}.tar.gz)
+license=('BSD')
+source=(http://miniupnp.free.fr/files/miniupnpc-${pkgver}.tar.gz)
md5sums=('48fd9c899f77e898c74d2166590da076')
prepare () {
- cp -rup $srcdir/${pkgbase#python-}-${pkgver} $srcdir/${pkgbase#python-}-${pkgver}-python2
+ cp -a miniupnpc{,-py2}-$pkgver
+ find miniupnpc-py2-$pkgver -name \*.py -exec sed -r 's|^#!(.*)python$|#!\1python2|' -i {} +
}
build() {
- cd $srcdir/${pkgbase#python-}-${pkgver}
+ echo "Building Python3"
+ cd miniupnpc-$pkgver
make
python setup.py build
- cd $srcdir/${pkgbase#python-}-${pkgver}-python2
+ echo "Building Python2"
+ cd ../miniupnpc-py2-$pkgver
make
python2 setup.py build
-
}
package_python-miniupnpc() {
depends=('python')
- conflicts=('python2-miniupnpc')
- cd $srcdir/${pkgbase#python-}-${pkgver}
+
+ cd miniupnpc-$pkgver
python setup.py install --root="$pkgdir" --optimize=1
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
package_python2-miniupnpc() {
depends=('python2')
- conflicts=('python-miniupnpc')
- cd $srcdir/${pkgbase#python-}-${pkgver}
+
+ cd miniupnpc-py2-$pkgver
python2 setup.py install --root="$pkgdir" --optimize=1
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}