summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJunYoung Gwak2020-02-19 20:34:08 -0800
committerJunYoung Gwak2020-02-19 20:34:08 -0800
commit2a8291757521852532ba59e45c17263ad7d2af88 (patch)
treee4a35bf87ef687f047d2d22582e1f0f0c95c8fe0
parent7fd2415b6ad26bb8c939390f431940c0eadc8648 (diff)
downloadaur-2a8291757521852532ba59e45c17263ad7d2af88.tar.gz
Force cblas option to setup.py.
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c0dc4f516c1a..6eb9d47d30a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-minkowskiengine-git
_pkgname=MinkowskiEngine
-pkgver=r195.fe836bd
+pkgver=r240.8d0316a
pkgrel=1
pkgdesc="Auto-diff library for generalized sparse convolutions"
url="https://github.com/StanfordVL/MinkowskiEngine"
@@ -29,12 +29,12 @@ prepare() {
export CUDA_HOME=/opt/cuda
# Use cblas, which is included in the community package.
# You may comment or change the following two lines to use other blas.
- sed -i "s/BLAS := open/BLAS := cblas/g" Makefile
+ sed -i "s/openblas/cblas/g" Makefile
sed -i "s/openblas/cblas/g" setup.py
}
package() {
cd "${srcdir}/${_pkgname}"
# Build isolation doesn't work in this library.
- python setup.py install --root="$pkgdir/" --optimize=1
+ python setup.py install --blas=cblas --root="$pkgdir/" --optimize=1
}