summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2019-03-07 14:07:31 +0100
committerPhilipp A2019-03-07 14:07:31 +0100
commit5df795b1ad1a615c6a174aba29e594d904369caa (patch)
tree212860532aaee11c74e319a7f710b94df1417e01
parent8fa8b276f8fa5a949a996ebf666344bd4307a004 (diff)
downloadaur-5df795b1ad1a615c6a174aba29e594d904369caa.tar.gz
v0.5.3
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb7788683c0a..15a0dfac4b6c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = python-mizani
pkgdesc = Scales for python
- pkgver = 0.5.2
+ pkgver = 0.5.3
pkgrel = 1
url = https://github.com/has2k1/mizani
arch = any
license = BSD
- makedepends = python-pip
depends = python
depends = python-numpy
depends = python-pandas>=0.23.4
depends = python-matplotlib
depends = python-palettable
- noextract = mizani-0.5.2-py2.py3-none-any.whl
- source = https://files.pythonhosted.org/packages/py2.py3/m/mizani/mizani-0.5.2-py2.py3-none-any.whl
- sha256sums = 52b6ead2633ff04c30dfba0fe3b662aa8d8291c1a64c9d37328d0dd99bbe8a63
+ noextract = mizani-0.5.3-py2.py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py2.py3/m/mizani/mizani-0.5.3-py2.py3-none-any.whl
+ sha256sums = dbb700cac139a47d3edd4eefa7646bd6415e83df48b369cf791ae674cc138a01
pkgname = python-mizani
diff --git a/PKGBUILD b/PKGBUILD
index 61383ab274e6..49de992c430e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=mizani
pkgname=python-$_name
-pkgver=0.5.2
+pkgver=0.5.3
pkgrel=1
pkgdesc='Scales for python'
arch=(any)
@@ -13,12 +13,14 @@ depends=(
python-matplotlib
python-palettable
)
-makedepends=(python-pip)
-_wheel="$_name-$pkgver-py2.py3-none-any.whl"
-source=("https://files.pythonhosted.org/packages/py2.py3/${_name::1}/$_name/$_wheel")
+_pyarch=py2.py3
+_wheel="${_name/-/_}-$pkgver-$_pyarch-none-any.whl"
+source=("https://files.pythonhosted.org/packages/$_pyarch/${_name::1}/$_name/$_wheel")
+sha256sums=('dbb700cac139a47d3edd4eefa7646bd6415e83df48b369cf791ae674cc138a01')
noextract=("$_wheel")
-sha256sums=('52b6ead2633ff04c30dfba0fe3b662aa8d8291c1a64c9d37328d0dd99bbe8a63')
package() {
- pip install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel"
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ mkdir -p "$site"
+ unzip "$_wheel" -d "$site"
}