summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2018-02-15 11:10:23 +0100
committerPhilipp A2018-02-15 11:10:23 +0100
commitb6b0bf4dc54e8730e8ed1ccec4482331aa1ee19b (patch)
treed005c0d37fcd56f241afd5aa67b8a882963a4f47
downloadaur-b6b0bf4dc54e8730e8ed1ccec4482331aa1ee19b.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0282856fecaf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-mizani
+ pkgdesc = Scales for python
+ pkgver = 0.4.4
+ pkgrel = 1
+ url = https://github.com/has2k1/mizani
+ arch = any
+ license = BSD
+ makedepends = python-pip
+ depends = python
+ depends = python-numpy
+ depends = python-palettable
+ depends = python-matplotlib
+ depends = python-pandas>=0.21.0
+ noextract = mizani-0.4.4-py2.py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py2.py3/m/mizani/mizani-0.4.4-py2.py3-none-any.whl
+ sha256sums = 7373086c97d65515a0e575e9a8dd45fb934e3b9ad0e9165a254ca38263e422d4
+
+pkgname = python-mizani
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4d7ad300862e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/*.whl
+/*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..da17d198a3b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+_name=mizani
+pkgname=python-$_name
+pkgver=0.4.4
+pkgrel=1
+pkgdesc='Scales for python'
+arch=(any)
+url="https://github.com/has2k1/$_name"
+license=(BSD)
+depends=(
+ python
+ python-numpy
+ python-palettable
+ python-matplotlib
+ 'python-pandas>=0.21.0'
+)
+makedepends=(python-pip)
+_wheel="$_name-$pkgver-py2.py3-none-any.whl"
+source=("https://files.pythonhosted.org/packages/py2.py3/${_name::1}/$_name/$_wheel")
+noextract=("$_wheel")
+sha256sums=('7373086c97d65515a0e575e9a8dd45fb934e3b9ad0e9165a254ca38263e422d4')
+
+package() {
+ pip install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel"
+}