summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrayden Banks2018-06-13 22:28:18 -0700
committerBrayden Banks2018-06-13 22:28:18 -0700
commit040f48a616e30cd3bffdbe98bdc09ddb8e030e30 (patch)
tree7a71ca1a5048e3383c83344111f368e0ceba96d1
downloadaur-040f48a616e30cd3bffdbe98bdc09ddb8e030e30.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore1
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD31
4 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ec5d23646fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-mkdocs-ponylang
+ pkgdesc = Ponylang Material theme for MkDocs
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/ponylang/mkdocs-theme
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = mkdocs
+ depends = pymdown-extensions
+ depends = python-pygments
+ depends = python-wheel
+ depends = twine
+ source = https://files.pythonhosted.org/packages/source/m/mkdocs-ponylang/mkdocs-ponylang-0.1.0.tar.gz
+ source = LICENSE
+ sha256sums = 26943868f967c3470e08d1576597665c1a4601df1051415afbea6c47adef2e2e
+ sha256sums = 25cc1bdc2b37c209bff6ebb460a75ed30641fd771d5ae0377271fbe884dcb3b6
+
+pkgname = python-mkdocs-ponylang
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f6a3a774d62a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+/*.tar.gz
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..cce1658484a1
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+Copyright (c) 2018, The Pony Developers
+Copyright (c) 2016-2018 Martin Donath <martin.donath@squidfunk.com>
+
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to
+deal in the Software without restriction, including without limitation the
+rights to use, copy, modify, merge, publish, distribute, sublicense, and/or
+sell copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
+IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23479f19a7ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: bb010g <bb010g@bb010g.com>
+pkgname=python-mkdocs-ponylang
+_name=${pkgname#python-}
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Ponylang Material theme for MkDocs"
+arch=(any)
+url="https://github.com/ponylang/mkdocs-theme"
+license=('MIT')
+depends=(mkdocs pymdown-extensions python-{pygments,wheel} twine)
+makedepends=(python-setuptools)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
+ "LICENSE")
+sha256sums=("26943868f967c3470e08d1576597665c1a4601df1051415afbea6c47adef2e2e"
+ "25cc1bdc2b37c209bff6ebb460a75ed30641fd771d5ae0377271fbe884dcb3b6")
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}