summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlphaJack2021-02-20 12:00:27 +0100
committerAlphaJack2021-02-20 12:04:42 +0100
commit5c10d781a2ab92e3e99c65519688a792e6eebff3 (patch)
treeef9c60d6711ee61f2aec3a30e2a24c90feab5eb0
parent040f48a616e30cd3bffdbe98bdc09ddb8e030e30 (diff)
downloadaur-5c10d781a2ab92e3e99c65519688a792e6eebff3.tar.gz
Adopted package and rewritten PKGBUILD
-rw-r--r--.SRCINFO12
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD39
3 files changed, 21 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ec5d23646fe..bec1f2f28ca2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
pkgbase = python-mkdocs-ponylang
pkgdesc = Ponylang Material theme for MkDocs
- pkgver = 0.1.0
+ pkgver = 0.2.8
pkgrel = 1
url = https://github.com/ponylang/mkdocs-theme
arch = any
license = MIT
makedepends = python-setuptools
+ makedepends = python-wheel
depends = mkdocs
depends = pymdown-extensions
depends = python-pygments
- depends = python-wheel
- depends = twine
- source = https://files.pythonhosted.org/packages/source/m/mkdocs-ponylang/mkdocs-ponylang-0.1.0.tar.gz
- source = LICENSE
- sha256sums = 26943868f967c3470e08d1576597665c1a4601df1051415afbea6c47adef2e2e
- sha256sums = 25cc1bdc2b37c209bff6ebb460a75ed30641fd771d5ae0377271fbe884dcb3b6
+ conflicts = python-mkdocs-material
+ source = https://github.com/ponylang/mkdocs-theme/archive/0.2.8.tar.gz
+ sha256sums = 3d2ff814f84b32c54975ffef12430428247ee4506105991d42e249ac8a1ac45f
pkgname = python-mkdocs-ponylang
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index cce1658484a1..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,21 +0,0 @@
-Copyright (c) 2018, The Pony Developers
-Copyright (c) 2016-2018 Martin Donath <martin.donath@squidfunk.com>
-
-
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to
-deal in the Software without restriction, including without limitation the
-rights to use, copy, modify, merge, publish, distribute, sublicense, and/or
-sell copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in
-all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
-FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
-IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 23479f19a7ee..ad98dcd1e131 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,24 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
+# Maintainer: AlphaJack <alphajack at tuta dot io>
-# Maintainer: bb010g <bb010g@bb010g.com>
-pkgname=python-mkdocs-ponylang
-_name=${pkgname#python-}
-pkgver=0.1.0
+pkgname="python-mkdocs-ponylang"
+pkgver=0.2.8
pkgrel=1
pkgdesc="Ponylang Material theme for MkDocs"
-arch=(any)
url="https://github.com/ponylang/mkdocs-theme"
-license=('MIT')
-depends=(mkdocs pymdown-extensions python-{pygments,wheel} twine)
-makedepends=(python-setuptools)
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
- "LICENSE")
-sha256sums=("26943868f967c3470e08d1576597665c1a4601df1051415afbea6c47adef2e2e"
- "25cc1bdc2b37c209bff6ebb460a75ed30641fd771d5ae0377271fbe884dcb3b6")
+license=("MIT")
+arch=("any")
+depends=("mkdocs" "pymdown-extensions" "python-pygments")
+conflicts=("python-mkdocs-material")
+makedepends=("python-setuptools" "python-wheel")
+source=("$url/archive/$pkgver.tar.gz")
+sha256sums=("3d2ff814f84b32c54975ffef12430428247ee4506105991d42e249ac8a1ac45f")
-build() {
- cd "$_name-$pkgver"
- python setup.py build
+build(){
+ cd "mkdocs-theme-$pkgver"
+ python setup.py build
}
-package() {
- cd "$_name-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+package(){
+ cd "mkdocs-theme-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
}