summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchrisjbillington2019-11-18 22:41:34 -0500
committerchrisjbillington2019-11-18 22:41:34 -0500
commit58ffa59c1df21a739ce9ab6f7b108ad7c47aee16 (patch)
treeafb7212802f605a449e09561baa7ca760dddc83a
parentfa51fd20dbf52f0ce5f55a2b0c459990850000eb (diff)
downloadaur-58ffa59c1df21a739ce9ab6f7b108ad7c47aee16.tar.gz
use upstream-compatible version string, sources from anaconda.com
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16dee25bf234..b6c046c23dd9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-mkl-fft-bin
pkgdesc = Fast Fourier Transform using Intel MKL - prebuilt binaries from Anaconda
- pkgver = 1.0.15
- pkgrel = 1
+ pkgver = 1.0.15.0.py38ha843d7b.0
+ pkgrel = 0
url = https://github.com/IntelPython/mkl_fft
arch = x86_64
license = custom
@@ -9,7 +9,7 @@ pkgbase = python-mkl-fft-bin
depends = python-numpy
provides = python-mkl-fft
conflicts = python-mkl-fft
- source = http://repo.continuum.io/pkgs/main/linux-64/mkl_fft-1.0.15-py38ha843d7b_0.tar.bz2
+ source = https://repo.anaconda.com/pkgs/main/linux-64/mkl_fft-1.0.15-py38ha843d7b_0.tar.bz2
sha256sums = ad24e954606f5183d31cc99b20c86d878963c5a75626815cfc056c266ccbb55d
pkgname = python-mkl-fft-bin
diff --git a/PKGBUILD b/PKGBUILD
index 7871df2339d6..5c0787429684 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,11 @@
# Maintainer : Chris Billington <chrisjbillington@gmail.com>
pkgname=python-mkl-fft-bin
_pkgname=mkl_fft
-pkgver=1.0.15
+_pkgver=1.0.15
_build=py38ha843d7b_0
-pkgrel=1
+_build_number=0
+pkgver="${_pkgver}.${_build_number}.${_build//_/.}"
+pkgrel=0
pkgdesc="Fast Fourier Transform using Intel MKL - prebuilt binaries from Anaconda"
arch=('x86_64')
url="https://github.com/IntelPython/mkl_fft"
@@ -11,11 +13,10 @@ license=('custom')
provides=('python-mkl-fft')
conflicts=('python-mkl-fft')
depends=('python-mkl-service' 'python-numpy')
-source=("http://repo.continuum.io/pkgs/main/linux-64/${_pkgname}-${pkgver}-${_build}.tar.bz2")
+source=("https://repo.anaconda.com/pkgs/main/linux-64/${_pkgname}-${_pkgver}-${_build}.tar.bz2")
sha256sums=('ad24e954606f5183d31cc99b20c86d878963c5a75626815cfc056c266ccbb55d')
package() {
- mkdir -p "${srcdir}/usr/"
mkdir "${pkgdir}/usr"
cp -drp --no-preserve=ownership "${srcdir}/lib" "${pkgdir}/usr/lib"
install -D -m 644 "${srcdir}/info/licenses/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"