summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-11-08 20:46:10 -0500
committeracxz2020-11-08 20:46:10 -0500
commit4f8d10feb5dbbae8f11042494af7a430c05f7588 (patch)
treef61c832d498f7a3b88ef5b417a7d5844c701ca53
parenta62bd41ee320dd5ef3a543d4ddd4edf723314669 (diff)
downloadaur-4f8d10feb5dbbae8f11042494af7a430c05f7588.tar.gz
updpkg 0.16.1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af349d68ad69..753c1fc14552 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-mleap
pkgdesc = Common serialization format and execution engine for machine learning pipelines (Python API)
- pkgver = 0.15.0
+ pkgver = 0.16.1
pkgrel = 1
url = https://mleap-docs.combust.ml
arch = x86_64
@@ -13,9 +13,8 @@ pkgbase = python-mleap
depends = python-scipy
depends = python-pandas
depends = python-scikit-learn
- depends = python-nose-exclude
- source = python-mleap-0.15.0::https://github.com/combust/mleap/archive/v0.15.0.tar.gz
- sha256sums = e88f4edd4c50cf74d6c01d18f70c15f5dd3a8c1cd2fdfeb4889c3e4a17c83b44
+ source = python-mleap-0.16.1::https://pypi.org/packages/source/m/mleap/mleap-0.16.1.tar.gz
+ sha256sums = a71b0b87bf904c2e7cd869841088f9166cce92fba05b52371c2c04d2c58d2547
pkgname = python-mleap
diff --git a/PKGBUILD b/PKGBUILD
index fdb626b5766a..995f6696724f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=python-mleap
-pkgver=0.15.0
+pkgver=0.16.1
pkgrel=1
pkgdesc='Common serialization format and execution engine for machine learning
pipelines (Python API)'
@@ -9,20 +9,20 @@ arch=('x86_64')
url='https://mleap-docs.combust.ml'
license=('Apache-2.0')
depends=('python' 'python-numpy' 'python-six' 'python-scipy' 'python-pandas'
- 'python-scikit-learn' 'python-nose-exclude')
+ 'python-scikit-learn')
optdepends=()
makedepends=('python' 'python-setuptools')
-source=("$pkgname-$pkgver::https://github.com/combust/mleap/archive/v$pkgver.tar.gz")
-sha256sums=('e88f4edd4c50cf74d6c01d18f70c15f5dd3a8c1cd2fdfeb4889c3e4a17c83b44')
+source=("$pkgname-$pkgver::https://pypi.org/packages/source/m/mleap/mleap-$pkgver.tar.gz")
+sha256sums=('a71b0b87bf904c2e7cd869841088f9166cce92fba05b52371c2c04d2c58d2547')
_pkgname=mleap
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}/python"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py build
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}/python"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
python setup.py install --root="$pkgdir"/ --optimize=1
}