summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-01-17 19:12:16 -0500
committeracxz2020-01-17 19:12:16 -0500
commita62bd41ee320dd5ef3a543d4ddd4edf723314669 (patch)
tree1054d27a168895e879a85503dc9c09fd50031673
downloadaur-a62bd41ee320dd5ef3a543d4ddd4edf723314669.tar.gz
create python-mleap package
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD28
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af349d68ad69
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-mleap
+ pkgdesc = Common serialization format and execution engine for machine learning pipelines (Python API)
+ pkgver = 0.15.0
+ pkgrel = 1
+ url = https://mleap-docs.combust.ml
+ arch = x86_64
+ license = Apache-2.0
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python
+ depends = python-numpy
+ depends = python-six
+ depends = python-scipy
+ depends = python-pandas
+ depends = python-scikit-learn
+ depends = python-nose-exclude
+ source = python-mleap-0.15.0::https://github.com/combust/mleap/archive/v0.15.0.tar.gz
+ sha256sums = e88f4edd4c50cf74d6c01d18f70c15f5dd3a8c1cd2fdfeb4889c3e4a17c83b44
+
+pkgname = python-mleap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fdb626b5766a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+
+pkgname=python-mleap
+pkgver=0.15.0
+pkgrel=1
+pkgdesc='Common serialization format and execution engine for machine learning
+pipelines (Python API)'
+arch=('x86_64')
+url='https://mleap-docs.combust.ml'
+license=('Apache-2.0')
+depends=('python' 'python-numpy' 'python-six' 'python-scipy' 'python-pandas'
+ 'python-scikit-learn' 'python-nose-exclude')
+optdepends=()
+makedepends=('python' 'python-setuptools')
+source=("$pkgname-$pkgver::https://github.com/combust/mleap/archive/v$pkgver.tar.gz")
+sha256sums=('e88f4edd4c50cf74d6c01d18f70c15f5dd3a8c1cd2fdfeb4889c3e4a17c83b44')
+
+_pkgname=mleap
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}/python"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}/python"
+ python setup.py install --root="$pkgdir"/ --optimize=1
+}