summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorButui Hu2020-08-27 16:10:21 +0800
committerButui Hu2020-08-27 16:10:21 +0800
commit12d135ca391b64f0372a7fda393b6bd50b9988d8 (patch)
tree24e5960394fce59879ef9adacda07186ff7305de
downloadaur-12d135ca391b64f0372a7fda393b6bd50b9988d8.tar.gz
first commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e8bd002746f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-mmclassification-git
+ pkgdesc = OpenMMLab Image Classification Toolbox and Benchmark
+ pkgver = 0.1.0.r149.4b46fd6
+ pkgrel = 1
+ url = https://github.com/open-mmlab/mmclassification
+ arch = any
+ license = Apache
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python-mmcv
+ depends = python-numpy
+ depends = python-pytorch
+ provides = python-mmclassification
+ conflicts = python-mmclassification
+ source = mmclassification::git+https://github.com/open-mmlab/mmclassification.git
+ sha512sums = SKIP
+
+pkgname = python-mmclassification-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ca7bdde4a8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Butui Hu <hot123tea123@gmail.com>
+
+_pkgname=mmclassification
+pkgname=python-mmclassification-git
+_pkgver=0.1.0
+pkgver=0.1.0.r149.4b46fd6
+pkgrel=1
+pkgdesc='OpenMMLab Image Classification Toolbox and Benchmark'
+arch=('any')
+url='https://github.com/open-mmlab/mmclassification'
+license=('Apache')
+depends=(
+ python-mmcv
+ python-numpy
+ python-pytorch
+)
+makedepends=(
+ git
+ python-setuptools
+)
+provides=(python-mmclassification)
+conflicts=(python-mmclassification)
+source=("${_pkgname}"::git+https://github.com/open-mmlab/mmclassification.git)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "%s.r%s.%s" "${_pkgver}" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
+# vim:set ts=2 sw=2 et: