summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2022-11-15 20:19:47 +0800
committerlilac2022-11-15 20:19:47 +0800
commit5bb569b3c293d6e6f230a3f44cae496ba133e835 (patch)
tree80cf373af03de551b0fef8a1d884c1b4cbef2bab
parentf7816dd9030dc6786f66ddf0647c508e65011453 (diff)
downloadaur-5bb569b3c293d6e6f230a3f44cae496ba133e835.tar.gz
[lilac] updated to 0.29.0-2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 354cac80798b..52f402ad0b7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-mmpose
pkgdesc = OpenMMLab Pose Estimation Toolbox and Benchmark
- pkgver = 0.28.1
- pkgrel = 1
+ pkgver = 0.29.0
+ pkgrel = 2
url = https://github.com/open-mmlab/mmpose
arch = any
license = Apache
@@ -23,7 +23,7 @@ pkgbase = python-mmpose
optdepends = python-onnxruntime
optdepends = python-requests
optdepends = python-trimesh
- source = python-mmpose-0.28.1.tar.gz::https://github.com/open-mmlab/mmpose/archive/refs/tags/v0.28.1.tar.gz
- sha512sums = fa5450fc5ae16f93fa5ebcb2c70bcba7e065a747ba2137f2970f8eb3eb588eac55054cd6d2455a887f56abe59eb768dc79814fe854e0e843641864c0b1d2e5ec
+ source = python-mmpose-0.29.0.tar.gz::https://github.com/open-mmlab/mmpose/archive/refs/tags/v0.29.0.tar.gz
+ sha512sums = 587cd6f181df62b7e6ee6775709ef47f626d91c0dd936912a087a8ac0d5c807e52087e29f4dbd4752caa0157554ef190012ce3100d7bd85fde3b7bea860ef5cc
pkgname = python-mmpose
diff --git a/PKGBUILD b/PKGBUILD
index 86946bfb166b..44aa3ba9834a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_pkgname=mmpose
pkgname=python-mmpose
-pkgver=0.28.1
-pkgrel=1
+pkgver=0.29.0
+pkgrel=2
pkgdesc='OpenMMLab Pose Estimation Toolbox and Benchmark'
arch=('any')
url='https://github.com/open-mmlab/mmpose'
@@ -33,7 +33,7 @@ optdepends=(
python-trimesh
)
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/open-mmlab/mmpose/archive/refs/tags/v${pkgver}.tar.gz")
-sha512sums=('fa5450fc5ae16f93fa5ebcb2c70bcba7e065a747ba2137f2970f8eb3eb588eac55054cd6d2455a887f56abe59eb768dc79814fe854e0e843641864c0b1d2e5ec')
+sha512sums=('587cd6f181df62b7e6ee6775709ef47f626d91c0dd936912a087a8ac0d5c807e52087e29f4dbd4752caa0157554ef190012ce3100d7bd85fde3b7bea860ef5cc')
build() {
cd "${_pkgname}-${pkgver}"
@@ -43,5 +43,7 @@ build() {
package() {
cd "${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ rm -rfv ${pkgdir}${site_packages}/tests
}
# vim:set ts=2 sw=2 et: