summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2023-05-09 23:03:10 +0800
committerlilac2023-05-09 23:03:10 +0800
commit2fa67852102e2be3eceb46cbd0a6d8c859164295 (patch)
tree59bb4286ff57fe8bbc1a23f65426f169c16e29e2
parente9f49d80881abc8375dd571704faf658e3f60c9f (diff)
downloadaur-2fa67852102e2be3eceb46cbd0a6d8c859164295.tar.gz
[lilac] updated to 1:1.0.0-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 100ae7c92e4d..e1a76b2bd969 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
pkgbase = python-mmsegmentation
pkgdesc = OpenMMLab Semantic Segmentation Toolbox and Benchmark
- pkgver = 0.30.0
+ pkgver = 1.0.0
pkgrel = 1
epoch = 1
url = https://github.com/open-mmlab/mmsegmentation
arch = any
license = Apache
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python-matplotlib
- depends = python-mmclassification
+ depends = python-mmpretrain
depends = python-mmcv
depends = python-numpy
depends = python-prettytable
- source = python-mmsegmentation-0.30.0.tar.gz::https://github.com/open-mmlab/mmsegmentation/archive/v0.30.0.tar.gz
- sha512sums = 41e83eab33bd48efb05fdc98c9fb7e49106d40ba015ffa3be67a778ec8a67867f462b83157a43b40a69039e0a57939c72b9a4085b64592646d86258f43628ea4
+ source = python-mmsegmentation-1.0.0.tar.gz::https://github.com/open-mmlab/mmsegmentation/archive/v1.0.0.tar.gz
+ sha512sums = 3555d52011d44f0aef1403ac630fc0a0137eb2b5b69bec02896cf04797789822e294f98582f0590521eacbbaff250c7e806dce664e3b714df76e3af969e8e915
pkgname = python-mmsegmentation
diff --git a/PKGBUILD b/PKGBUILD
index ba571e089964..4d49cd4bd047 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=mmsegmentation
pkgname=python-mmsegmentation
-pkgver=0.30.0
+pkgver=1.0.0
pkgrel=1
epoch=1
pkgdesc='OpenMMLab Semantic Segmentation Toolbox and Benchmark'
@@ -11,27 +11,31 @@ url='https://github.com/open-mmlab/mmsegmentation'
license=('Apache')
depends=(
python-matplotlib
- python-mmclassification
+ python-mmpretrain
python-mmcv
python-numpy
python-prettytable
)
makedepends=(
+ python-build
+ python-installer
python-setuptools
+ python-wheel
)
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/open-mmlab/mmsegmentation/archive/v${pkgver}.tar.gz")
-sha512sums=('41e83eab33bd48efb05fdc98c9fb7e49106d40ba015ffa3be67a778ec8a67867f462b83157a43b40a69039e0a57939c72b9a4085b64592646d86258f43628ea4')
+sha512sums=('3555d52011d44f0aef1403ac630fc0a0137eb2b5b69bec02896cf04797789822e294f98582f0590521eacbbaff250c7e806dce664e3b714df76e3af969e8e915')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
cd "${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- # remove unneeded files
- rm -rf "${pkgdir}${site_packages}/tests"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+ # remove unused .mim and tests dir
+ rm -rfv "${pkgdir}${site_packages}/mmseg/.mim"
+ rm -rfv "${pkgdir}${site_packages}/tests"
}
# vim:set ts=2 sw=2 et: