summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Rubin2022-04-17 18:51:17 +0200
committerMarco Rubin2022-04-17 18:51:17 +0200
commit5d61c633f3d983b35161f97a789e36e562d3cdd6 (patch)
treef8903677ebcd5d03f203931be370bfa9106d4a2e
downloadaur-5d61c633f3d983b35161f97a789e36e562d3cdd6.tar.gz
First release
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..94b859235c3f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-moderngl
+ pkgdesc = ModernGL: High performance rendering for Python 3
+ pkgver = 5.6.4
+ pkgrel = 1
+ url = https://github.com/moderngl/moderngl
+ arch = x86_64
+ license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/m/moderngl/moderngl-5.6.4.tar.gz
+ sha256sums = 8c6d04559f5e3bf75a18525cd46d213c0f3a8409363718978e6de691bdb551fb
+
+pkgname = python-moderngl
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1646bca56307
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Marco Rubin <marco.rubin@protonmail.com>
+
+_name=moderngl
+pkgname=python-$_name
+pkgver=5.6.4
+pkgrel=1
+pkgdesc='ModernGL: High performance rendering for Python 3'
+arch=(x86_64)
+url='https://github.com/moderngl/moderngl'
+license=('MIT')
+depends=(python)
+makedepends=(python-build python-installer python-wheel)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('8c6d04559f5e3bf75a18525cd46d213c0f3a8409363718978e6de691bdb551fb')
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}