summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Heitzmann Gabrielli2017-07-28 09:04:29 -0300
committerLucas Heitzmann Gabrielli2017-07-28 09:04:29 -0300
commit406caf26ae5c20cce7d08a8e868aa53d13cec724 (patch)
treec6078b632ab4a95429931c8bbb1676b26d35a512
downloadaur-406caf26ae5c20cce7d08a8e868aa53d13cec724.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b69e50493315
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-moderngl-git
+ pkgdesc = Modern OpenGL binding for python.
+ pkgver = 20170726
+ pkgrel = 1
+ url = https://github.com/cprogrammer1994/ModernGL
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = python
+ depends = libgl
+ options = !emptydirs
+ source = git+https://github.com/cprogrammer1994/ModernGL.git
+ md5sums = SKIP
+
+pkgname = python-moderngl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..653e4aaa4899
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Lucas H. Gabrielli <heitzmann@gmail.com>
+
+pkgname=python-moderngl-git
+pkgdesc="Modern OpenGL binding for python."
+pkgver=20170726
+pkgrel=1
+arch=('i686' 'x86_64')
+url="https://github.com/cprogrammer1994/ModernGL"
+license=('MIT')
+groups=()
+depends=('python' 'libgl')
+makedepends=('git')
+options=(!emptydirs)
+source=("git+https://github.com/cprogrammer1994/ModernGL.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ModernGL
+ git log --format="%cd" --date=short -1 | sed 's/-//g'
+}
+
+build() {
+ cd ModernGL
+ python setup.py build
+}
+
+package() {
+ cd ModernGL
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: shiftwidth=2 softtabstop=2 tabstop=2 noexpandtab