summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2019-03-07 13:39:50 +0100
committerPhilipp A2019-03-07 13:39:50 +0100
commitf0ea4349e6d6c0eb460570bab3cb01764d28d76d (patch)
treee0f38cc462362dc00eb40e6c9557b1ab50e8634d
parentbe9d42f61e26a4ab792c26192c9fc9041ff370bf (diff)
downloadaur-f0ea4349e6d6c0eb460570bab3cb01764d28d76d.tar.gz
v0.17
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 25 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e98626d23916..36830b073c30 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = python-modulegraph
pkgdesc = determines a dependency graph between Python modules primarily by bytecode analysis for import statements
- pkgver = 0.12.1
- pkgrel = 2
+ pkgver = 0.17
+ pkgrel = 1
url = https://bitbucket.org/ronaldoussoren/modulegraph
arch = any
+ license = MIT
depends = python
depends = python-altgraph
- source = https://pypi.python.org/packages/source/m/modulegraph/modulegraph-0.12.1.tar.gz
- md5sums = 27abd74de3ec0e22ef129c1faa628bd5
+ noextract = modulegraph-0.17-py2.py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py2.py3/m/modulegraph/modulegraph-0.17-py2.py3-none-any.whl
+ sha256sums = 9991538487efaa2d77b78bded12f7ba223f1a143f8ad75ed6484afa70b3d47e1
pkgname = python-modulegraph
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4d7ad300862e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/*.whl
+/*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index e0ad71ec296b..5fc1b39049f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,22 @@
-# Maintainer: Phil Schaf <flying-sheep@web.de>
+# Maintainer: Philipp A. <flying-sheep@web.de>
+
_name=modulegraph
pkgname=python-modulegraph
-pkgver=0.12.1
-pkgrel=2
+pkgver=0.17
+pkgrel=1
pkgdesc='determines a dependency graph between Python modules primarily by bytecode analysis for import statements'
arch=('any')
-url="https://bitbucket.org/ronaldoussoren/modulegraph"
-license=('')
+url="https://bitbucket.org/ronaldoussoren/$_name"
+license=('MIT')
depends=('python' 'python-altgraph')
-source=("https://pypi.python.org/packages/source/m/$_name/$_name-$pkgver.tar.gz")
-md5sums=('27abd74de3ec0e22ef129c1faa628bd5')
+_pyarch=py2.py3
+_wheel="${_name/-/_}-$pkgver-$_pyarch-none-any.whl"
+source=("https://files.pythonhosted.org/packages/$_pyarch/${_name::1}/$_name/$_wheel")
+sha256sums=('9991538487efaa2d77b78bded12f7ba223f1a143f8ad75ed6484afa70b3d47e1')
+noextract=("$_wheel")
package() {
- cd "$srcdir/$_name-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 || return 1
-} \ No newline at end of file
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ mkdir -p "$site"
+ unzip "$_wheel" -d "$site"
+}