summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbitwave2019-09-15 12:31:27 +0200
committerbitwave2019-09-15 12:31:27 +0200
commit5bcf2829af7830f08db8d374c7b82fb414fb8e99 (patch)
tree19d00969fe133bd51c7d494fba0dfbcb220b2752
parent59400bce538927dc47ca7957a5b4b4e33aa4a1b8 (diff)
downloadaur-5bcf2829af7830f08db8d374c7b82fb414fb8e99.tar.gz
updated to 1.0.0
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD36
2 files changed, 37 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94e40292765c..ff53a1639b4a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
-# Generated by mksrcinfo v8
-# Wed Aug 1 08:00:33 UTC 2018
pkgbase = python-moviepy
- pkgdesc = Script-based movie editing with python
- pkgver = 0.2.3.5
+ pkgdesc = Video editing with Python
+ pkgver = 1.0.0
pkgrel = 1
- url = http://zulko.github.io/moviepy/
+ url = https://zulko.github.io/moviepy/
arch = any
license = MIT
makedepends = python-setuptools
+ depends = python
depends = ffmpeg
depends = imagemagick
depends = opencv
@@ -18,10 +17,19 @@ pkgbase = python-moviepy
depends = python-scipy
depends = python-tqdm
depends = python-imageio
- provides = python-moviepy-git
- conflicts = python-moviepy-git
- source = https://github.com/Zulko/moviepy/archive/v0.2.3.5.tar.gz
- sha256sums = 2c05515f5a3ff4225be192ef560b0328348899a64f566548efe131243eb9eb8d
+ source = https://files.pythonhosted.org/packages/source/m/moviepy/moviepy-1.0.0.tar.gz
+ sha256sums = 16c7ffca23d90c76dd7b163f648c8166dfd589b7c180b8ff75aa327ae0a2fc6d
pkgname = python-moviepy
+ depends = python
+ depends = ffmpeg
+ depends = imagemagick
+ depends = opencv
+ depends = python-decorator
+ depends = python-numpy
+ depends = python-pillow
+ depends = python-scikit-image
+ depends = python-scipy
+ depends = python-tqdm
+ depends = python-imageio
diff --git a/PKGBUILD b/PKGBUILD
index 3062cc0ef0af..250ab4f0bb91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,25 @@
-_pkgname=moviepy
-pkgname=python-${_pkgname}
-pkgver=0.2.3.5
+pkgbase='python-moviepy'
+pkgname=('python-moviepy')
+_module='moviepy'
+pkgver='1.0.0'
pkgrel=1
-pkgdesc="Script-based movie editing with python"
-arch=('any')
-url="http://zulko.github.io/moviepy/"
-license=("MIT")
+pkgdesc="Video editing with Python"
+url="https://zulko.github.io/moviepy/"
+depends=('python' 'ffmpeg' 'imagemagick' 'opencv'
+ 'python-decorator' 'python-numpy' 'python-pillow' 'python-scikit-image' 'python-scipy' 'python-tqdm' 'python-imageio')
makedepends=('python-setuptools')
-depends=('ffmpeg' 'imagemagick' 'opencv'
- 'python-decorator' 'python-numpy' 'python-pillow' 'python-scikit-image' 'python-scipy' 'python-tqdm' 'python-imageio')
-optdepens=('python-pygame')
-provides=('python-moviepy-git')
-conflicts=('python-moviepy-git')
-source=(https://github.com/Zulko/${_pkgname}/archive/v${pkgver}.tar.gz)
-sha256sums=('2c05515f5a3ff4225be192ef560b0328348899a64f566548efe131243eb9eb8d')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('16c7ffca23d90c76dd7b163f648c8166dfd589b7c180b8ff75aa327ae0a2fc6d')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}