summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-03-02 12:21:38 -0500
committerCarlos Aznarán Laos2023-03-02 12:21:38 -0500
commit0bbfdde88fe8fea51038c918cf1b742ec40e7828 (patch)
treea551d50bf327933fe9593d7c6c03438395563b07
parenta54a2273145fa51230275528512b63da1fced21e (diff)
downloadaur-0bbfdde88fe8fea51038c918cf1b742ec40e7828.tar.gz
Bump version to 3.1.4
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD64
2 files changed, 52 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c679fdf4a5e3..b4eeffa9211b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = python-mpi4py-intel
pkgdesc = Python bindings for the Message Passing Interface compiled with intel mpi
- pkgver = 3.0.3
- pkgrel = 2
+ pkgver = 3.1.4
+ pkgrel = 1
url = https://github.com/mpi4py/mpi4py
- arch = any
- license = custom
+ arch = x86_64
+ license = custom:BSD-2-clause
makedepends = python-setuptools
- depends = intel-mpi
+ makedepends = cython
+ depends = python
+ depends = intel-oneapi-compiler
provides = python-mpi4py
conflicts = python-mpi4py
options = !emptydirs
- source = https://github.com/mpi4py/mpi4py/archive/3.0.3.tar.gz
- sha256sums = 1df2c50e83174a965f55ee31782e5d84388a68c618c0a3c697a63247fe6409cb
+ source = mpi4py-3.1.4.tar.gz::https://github.com/mpi4py/mpi4py/archive/3.1.4.tar.gz
+ sha512sums = 074ac690c7606e104b6f7a82c03eb99906f6efe2556c0ecba14a8949a3f9b263d7a75b7f714c37c83ac971fbee3e60bd0bbb3110b37ee9bd9a6fdc5041d78095
pkgname = python-mpi4py-intel
-
diff --git a/PKGBUILD b/PKGBUILD
index d3960a6923fa..f13502c0629b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,47 @@
-# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
-_modulename=mpi4py-intel
-pkgname=python-$_modulename
-pkgver=3.0.3
-pkgrel=2
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+# Based on python-mpi4py, maintained by Bruno Pagani <archange@archlinux.org> and et.al.
+_base=mpi4py
+pkgname=python-${_base}-intel
+pkgver=3.1.4
+pkgrel=1
pkgdesc="Python bindings for the Message Passing Interface compiled with intel mpi"
-arch=(any)
-url="https://github.com/mpi4py/mpi4py"
-license=('custom')
-groups=()
-depends=('intel-mpi')
-makedepends=('python-setuptools')
-provides=('python-mpi4py')
-conflicts=('python-mpi4py')
-replaces=()
-backup=()
+arch=(x86_64)
+url="https://github.com/${_base}/${_base}"
+license=('custom:BSD-2-clause')
+depends=(python intel-oneapi-compiler) # "intel-oneapi-mpi=2023.0.0"
+makedepends=(python-setuptools cython)
+provides=(python-${_base})
+conflicts=(python-${_base})
options=(!emptydirs)
-install=
-source=("${url}/archive/${pkgver}.tar.gz")
-sha256sums=('1df2c50e83174a965f55ee31782e5d84388a68c618c0a3c697a63247fe6409cb')
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
+sha512sums=('074ac690c7606e104b6f7a82c03eb99906f6efe2556c0ecba14a8949a3f9b263d7a75b7f714c37c83ac971fbee3e60bd0bbb3110b37ee9bd9a6fdc5041d78095')
+
+build() {
+ cd ${_base}-${pkgver}
+ source /opt/intel/oneapi/setvars.sh # intel-oneapi-common
+ source /opt/intel/oneapi/compiler/2023.0.0/env/vars.sh # intel-oneapi-compiler
+ # https://aur.archlinux.org/packages/intel-oneapi-compiler#comment-856804
+ CC=icx MPICC=mpiicc LDFLAGS="-shared-intel" python setup.py build
+}
+
+# check() {
+# if [ -z "$(ldconfig -p | grep libcuda.so.1)" ]; then
+# # We don’t have CUDA by default
+# export OMPI_MCA_opal_warn_on_missing_libcuda=0
+# fi
+
+# # This is required starting with OpenMPI 3.0 when trying to run more
+# # processes than the number of available cores
+# export OMPI_MCA_rmaps_base_oversubscribe=yes
+
+# cd ${_base}-${pkgver}
+# local _pyversion=$(python -c "import sys; print(f'{sys.version_info.major}.{sys.version_info.minor}')")
+# PYTHONPATH="${PWD}"/build/lib.linux-${CARCH}-cpython-${_pyversion/./} python setup.py test
+# }
+
package() {
- cd "$srcdir/mpi4py-$pkgver"
- export MPICC=mpiicc
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 LICENSE.rst -t "${pkgdir}/usr/share/licenses/${pkgname}"
}