summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2019-03-11 13:00:38 +0100
committerPhilip Goto2019-03-11 13:00:38 +0100
commit219173605b519666820999b7b21f92bf34eedbf3 (patch)
tree2db37326dda2528a766ca07c8e196b57a10eb79f
downloadaur-219173605b519666820999b7b21f92bf34eedbf3.tar.gz
Initialize package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d77ab680d907
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-msgpack-numpy
+ pkgdesc = Serialize numpy arrays using msgpack
+ pkgver = 0.4.4.2
+ pkgrel = 1
+ url = https://pypi.org/project/msgpack-numpy/
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python-numpy
+ depends = python-msgpack
+ source = https://files.pythonhosted.org/packages/b8/70/5d804a4ff26788d5b5abcebeb57498e45c33816957edb5cea38982c69a93/msgpack-numpy-0.4.4.2.tar.gz
+ sha256sums = a1638108538aaba55bebaef9d847dfb3064bb1c829e68301716a6a956fa6a0d6
+
+pkgname = python-msgpack-numpy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5ea9d57aa21
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+pkgname=python-msgpack-numpy
+pkgver=0.4.4.2
+pkgrel=1
+pkgdesc="Serialize numpy arrays using msgpack"
+url="https://pypi.org/project/msgpack-numpy/"
+depends=(python-numpy
+ python-msgpack)
+makedepends=(python-setuptools)
+license=(BSD)
+arch=(any)
+source=("https://files.pythonhosted.org/packages/b8/70/5d804a4ff26788d5b5abcebeb57498e45c33816957edb5cea38982c69a93/msgpack-numpy-0.4.4.2.tar.gz")
+sha256sums=('a1638108538aaba55bebaef9d847dfb3064bb1c829e68301716a6a956fa6a0d6')
+
+build(){
+ cd "msgpack-numpy-${pkgver}"
+ python setup.py build
+}
+
+package(){
+ cd "msgpack-numpy-${pkgver}"
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE.rst "$pkgdir/usr/share/licenses/$pkgname/LICENSE.rst"
+}