summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Yantis2015-06-11 08:59:53 -0700
committerJonathan Yantis2015-06-11 08:59:53 -0700
commita986d58704b0695dfb2c2fb22506d1068e0f2ab0 (patch)
tree08c696e72f099cd8ee1a3ffdf7e3fa608ba26580
downloadaur-a986d58704b0695dfb2c2fb22506d1068e0f2ab0.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD43
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f1cc80579124
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-msgpack-numpy-git
+ pkgdesc = Python 3 package that provides encoding and decoding routines that enable the serialization and deserialization of numerical and array data types provided by numpy using the highly efficient msgpack format.
+ pkgver = 0.3.2.r15.gd6603cd
+ pkgrel = 2
+ url = https://github.com/lebedov/msgpack-numpy
+ arch = any
+ license = BSD
+ makedepends = git
+ depends = python
+ depends = python-numpy
+ depends = python-msgpack
+ provides = python-msgpack-numpy
+ conflicts = python-msgpack-numpy
+ source = git+https://github.com/lebedov/msgpack-numpy
+ sha256sums = SKIP
+
+pkgname = python-msgpack-numpy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2054dfa8c328
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: jyantis <yantis@yantis.net>
+
+pkgname=python-msgpack-numpy-git
+pkgver=0.3.2.r15.gd6603cd
+_gitname=msgpack-numpy
+pkgrel=2
+pkgdesc='Python 3 package that provides encoding and decoding routines that enable the serialization and deserialization of numerical and array data types provided by numpy using the highly efficient msgpack format.'
+arch=('any')
+url='https://github.com/lebedov/msgpack-numpy'
+license=('BSD')
+depends=('python'
+ 'python-numpy'
+ 'python-msgpack')
+source=('git+https://github.com/lebedov/msgpack-numpy')
+sha256sums=('SKIP')
+makedepends=('git')
+provides=('python-msgpack-numpy')
+conflicts=('python-msgpack-numpy')
+
+pkgver() {
+ cd "$_gitname"
+ set -o pipefail
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+check() {
+ cd ${_gitname}
+ python setup.py test --verbose
+}
+
+build() {
+ cd ${_gitname}
+ python setup.py build
+}
+
+package() {
+ cd ${_gitname}
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -D -m644 LICENSE.rst "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.rst"
+}
+
+# vim:set ts=2 sw=2 et: