summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanManN2018-12-05 18:49:01 -0500
committerDanManN2018-12-05 18:49:01 -0500
commitfebd2b8490b9063b189b95b271060f5532d158c2 (patch)
treed6655be97edda66b2404b3c449927f2b98530d96
parenta986d58704b0695dfb2c2fb22506d1068e0f2ab0 (diff)
downloadaur-febd2b8490b9063b189b95b271060f5532d158c2.tar.gz
change pkver command
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD28
2 files changed, 15 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1cc80579124..b224518e73b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-msgpack-numpy-git
pkgdesc = Python 3 package that provides encoding and decoding routines that enable the serialization and deserialization of numerical and array data types provided by numpy using the highly efficient msgpack format.
- pkgver = 0.3.2.r15.gd6603cd
- pkgrel = 2
+ pkgver = 0.4.4.2.r95.ff6901d
+ pkgrel = 3
url = https://github.com/lebedov/msgpack-numpy
arch = any
license = BSD
@@ -11,7 +11,7 @@ pkgbase = python-msgpack-numpy-git
depends = python-msgpack
provides = python-msgpack-numpy
conflicts = python-msgpack-numpy
- source = git+https://github.com/lebedov/msgpack-numpy
+ source = git+https://github.com/lebedov/msgpack-numpy.git
sha256sums = SKIP
pkgname = python-msgpack-numpy-git
diff --git a/PKGBUILD b/PKGBUILD
index 2054dfa8c328..544e31c2d460 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
-# Maintainer: jyantis <yantis@yantis.net>
-
+# Maintainer: DanManN <dnahimov@gmail.com>
+# Contributor: jyantis <yantis@yantis.net>
pkgname=python-msgpack-numpy-git
-pkgver=0.3.2.r15.gd6603cd
+pkgver=0.4.4.2.r95.ff6901d
_gitname=msgpack-numpy
-pkgrel=2
-pkgdesc='Python 3 package that provides encoding and decoding routines that enable the serialization and deserialization of numerical and array data types provided by numpy using the highly efficient msgpack format.'
+pkgrel=3
+pkgdesc="Python 3 package that provides encoding and decoding routines that enable the serialization and deserialization of numerical and array data types provided by numpy using the highly efficient msgpack format."
arch=('any')
url='https://github.com/lebedov/msgpack-numpy'
license=('BSD')
depends=('python'
'python-numpy'
'python-msgpack')
-source=('git+https://github.com/lebedov/msgpack-numpy')
+source=('git+https://github.com/lebedov/msgpack-numpy.git')
sha256sums=('SKIP')
makedepends=('git')
provides=('python-msgpack-numpy')
@@ -19,9 +19,7 @@ conflicts=('python-msgpack-numpy')
pkgver() {
cd "$_gitname"
- set -o pipefail
- git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "%s.r%s.%s" "$(cat setup.py | grep -i version | cut -d "'" -f2 | head -n 1)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
check() {
@@ -30,14 +28,12 @@ check() {
}
build() {
- cd ${_gitname}
- python setup.py build
+ cd ${_gitname}
+ python setup.py build
}
package() {
- cd ${_gitname}
- python setup.py install --root="${pkgdir}" --optimize=1
- install -D -m644 LICENSE.rst "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.rst"
+ cd ${_gitname}
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -D -m644 LICENSE.rst "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.rst"
}
-
-# vim:set ts=2 sw=2 et: