summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora8212021-01-11 19:10:17 +0100
committera8212021-01-11 19:10:17 +0100
commitffb2d6f1e7c0a51f1e25cbec171feb55357d28af (patch)
treec3639c944d954237d8c381b4288f0b428e101dbf
parent02fc49b3052120f86b2e3fd0628e5d89563e3ddd (diff)
downloadaur-ffb2d6f1e7c0a51f1e25cbec171feb55357d28af.tar.gz
Takeover and cleanup
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba942c30c59f..bd3906a4c823 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = python-msgpack-numpy-git
- pkgdesc = Python 3 package that provides encoding and decoding routines that enable the serialization and deserialization of numerical and array data types provided by numpy using the highly efficient msgpack format.
- pkgver = 0.4.4.2.r95.ff6901d
- pkgrel = 4
+ pkgdesc = Serialize numpy arrays using msgpack
+ pkgver = 0.4.7.1.r0.g963db59
+ pkgrel = 1
url = https://github.com/lebedov/msgpack-numpy
arch = any
license = BSD
makedepends = git
makedepends = python-setuptools
- depends = python
depends = python-numpy
depends = python-msgpack
provides = python-msgpack-numpy
diff --git a/PKGBUILD b/PKGBUILD
index 9eb3c0e19c70..a23297073d9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,14 @@
# Maintainer: DanManN <dnahimov@gmail.com>
# Contributor: jyantis <yantis@yantis.net>
pkgname=python-msgpack-numpy-git
-pkgver=0.4.4.2.r95.ff6901d
+pkgver=0.4.7.1.r0.g963db59
_gitname=msgpack-numpy
-pkgrel=4
-pkgdesc="Python 3 package that provides encoding and decoding routines that enable the serialization and deserialization of numerical and array data types provided by numpy using the highly efficient msgpack format."
+pkgrel=1
+pkgdesc="Serialize numpy arrays using msgpack"
arch=('any')
url='https://github.com/lebedov/msgpack-numpy'
license=('BSD')
-depends=('python'
- 'python-numpy'
+depends=('python-numpy'
'python-msgpack')
source=('git+https://github.com/lebedov/msgpack-numpy.git')
sha256sums=('SKIP')
@@ -18,13 +17,13 @@ provides=('python-msgpack-numpy')
conflicts=('python-msgpack-numpy')
pkgver() {
- cd "$_gitname"
- printf "%s.r%s.%s" "$(cat setup.py | grep -i version | cut -d "'" -f2 | head -n 1)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd ${_gitname}
+ git describe --tags --long | sed 's/-/.r/;s/-/./'
}
check() {
cd ${_gitname}
- python setup.py test --verbose
+ python setup.py test
}
build() {
@@ -35,5 +34,5 @@ build() {
package() {
cd ${_gitname}
python setup.py install --root="${pkgdir}" --optimize=1
- install -D -m644 LICENSE.rst "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.rst"
+ install -D -m644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
}