summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHector Mtz-Seara2016-03-10 12:08:12 +0100
committerHector Mtz-Seara2016-03-10 12:08:12 +0100
commitd32b0a36f30322e19fcec3b13aba31556db77f6e (patch)
tree7e729d66aa74627e9e436ee4c76b1a83b80878a0
parent8d526c49135bc4f0cbefa5d910369407a0c3d475 (diff)
downloadaur-d32b0a36f30322e19fcec3b13aba31556db77f6e.tar.gz
Added python-mdtraj to general makedepends as it does not seem to work inside the split package function
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD27
2 files changed, 16 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92d9345fc646..f44db935ba5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = python-msmbuilder
pkgdesc = A python package which implements a series of statistical models for high-dimensional time-series
pkgver = 3.3.1
- pkgrel = 2
+ pkgrel = 3
url = http://msmbuilder.org/
arch = i686
arch = x86_64
license = LGPL
+ makedepends = python-mdtraj
+ makedepends = python2-mdtraj
makedepends = python2-setuptools
makedepends = python-setuptools
- depends = python-numpydoc
options = !libtool
source = https://github.com/msmbuilder/msmbuilder/archive/3.3.1.tar.gz
source = patch.i0.c
@@ -19,11 +20,13 @@ pkgname = python2-msmbuilder
depends = python2-mdtraj
depends = python2-cvxopt
depends = python2-scikit-learn
- optdepends = python2-mdtraj
+ depends = python2-numpydoc
+ optdepends =
pkgname = python-msmbuilder
depends = python-mdtraj
depends = python-cvxopt
depends = python-scikit-learn
- optdepends = python-mdtraj
+ depends = python-numpydoc
+ optdepends =
diff --git a/PKGBUILD b/PKGBUILD
index a0a7da4fe53e..5dcfedddd746 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,13 @@
pkgbase=python-msmbuilder
pkgname=('python2-msmbuilder' 'python-msmbuilder')
pkgver=3.3.1
-pkgrel=2
+pkgrel=3
pkgdesc='A python package which implements a series of statistical models for high-dimensional time-series'
url='http://msmbuilder.org/'
license=("LGPL")
arch=('i686' 'x86_64')
-depends=('python-numpydoc')
-#depends=('python2-numpydoc' 'python-numpydoc')
-makedepends=('python2-setuptools' 'python-setuptools')
+depends=()
+makedepends=('python-mdtraj' 'python2-mdtraj' 'python2-setuptools' 'python-setuptools')
options=('!libtool')
source=("https://github.com/msmbuilder/msmbuilder/archive/${pkgver}.tar.gz"
"patch.i0.c")
@@ -28,19 +27,10 @@ prepare() {
cp -a msmbuilder-${pkgver} msmbuilder-py2-${pkgver}
}
-#build() {
-# msg2 "Building msmbuilder - Python2"
-# cd "${srcdir}/msmbuilder-py2-${pkgver}"
-# python2 setup.py build
-#
-# msg2 "Building msmbuilder - Python3"
-# cd "${srcdir}/msmbuilder-${pkgver}"
-# python setup.py build
-#}
-
package_python-msmbuilder() {
- depends=('python-mdtraj' 'python-cvxopt' 'python-scikit-learn')
- optdepends=('python-mdtraj')
+ depends=('python-mdtraj' 'python-cvxopt' 'python-scikit-learn' 'python-numpydoc')
+ makedepends=('python-setuptools')
+ optdepends=()
cd "${srcdir}/msmbuilder-${pkgver}"
msg2 "Building msmbuilder - Python3"
@@ -54,8 +44,9 @@ package_python-msmbuilder() {
}
package_python2-msmbuilder() {
- depends=('python2-mdtraj' 'python2-cvxopt' 'python2-scikit-learn')
- optdepends=('python2-mdtraj')
+ depends=('python2-mdtraj' 'python2-cvxopt' 'python2-scikit-learn' 'python2-numpydoc')
+ makedepends=('python2-setuptools')
+ optdepends=()
cd "${srcdir}/msmbuilder-py2-${pkgver}"
msg2 "Building msmbuilder - Python2"