summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKelsey Maes2017-03-17 18:26:01 -0700
committerKelsey Maes2017-03-17 18:26:01 -0700
commit84601737555058e752fb5938f7b139c9e9785b7d (patch)
treef7533bb0ba2b6e8ddce4074f8b667083066a7bff
downloadaur-84601737555058e752fb5938f7b139c9e9785b7d.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa2003d9d5e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-msrest
+ pkgdesc = The runtime library for AutoRest generated Python clients.
+ pkgver = 0.4.6
+ pkgrel = 1
+ url = https://github.com/Azure/msrest-for-python
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-isodate
+ depends = python-requests-oauthlib
+ source = https://github.com/Azure/msrest-for-python/archive/v0.4.6.tar.gz
+ md5sums = 5b8872e572a81bac7bb78aecd6b96297
+
+pkgname = python-msrest
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d44649a5e41
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Kelsey Maes <kelseymaes at outlook dot com>
+pkgname=python-msrest
+pkgver=0.4.6
+pkgrel=1
+pkgdesc='The runtime library for AutoRest generated Python clients.'
+arch=('any')
+url="https://github.com/Azure/msrest-for-python"
+license=('MIT')
+depends=('python-isodate' 'python-requests-oauthlib')
+makedepends=('python-setuptools')
+source=("https://github.com/Azure/msrest-for-python/archive/v0.4.6.tar.gz")
+md5sums=('5b8872e572a81bac7bb78aecd6b96297')
+
+build() {
+ cd "msrest-for-python-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "msrest-for-python-$pkgver"
+ python setup.py install --root="$pkgdir"
+} \ No newline at end of file