summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2018-11-27 23:00:09 +0000
committerGrey Christoforo2018-11-27 23:00:09 +0000
commit96ba6dea115a6c340fdd4c0fed218128d4f23ab8 (patch)
tree51d490f9c509f3705968f0f88a4e9fa281b3452e
downloadaur-96ba6dea115a6c340fdd4c0fed218128d4f23ab8.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5eec998df76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-mss
+ pkgdesc = An ultra fast cross-platform multiple screenshots module in pure python using ctypes.
+ pkgver = 3.3.2
+ pkgrel = 1
+ url = https://github.com/BoboTiG/python-mss
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = https://files.pythonhosted.org/packages/source/m/mss/mss-3.3.2.tar.gz
+ md5sums = e9bc7dbd2551b56f4baeb58f5093d092
+
+pkgname = python-mss
+ depends = python
+
+pkgname = python2-mss
+ depends = python2
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..93f5d9f2777e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6038439a0f16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Grey Christoforo <first name at last name dot net>
+
+pkgbase=python-mss
+pkgname=('python-mss' 'python2-mss')
+_module='mss'
+pkgver=3.3.2
+pkgrel=1
+pkgdesc="An ultra fast cross-platform multiple screenshots module in pure python using ctypes."
+url="https://github.com/BoboTiG/python-mss"
+depends=()
+makedepends=('python-setuptools' 'python2-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/m/mss/mss-${pkgver}.tar.gz")
+md5sums=('e9bc7dbd2551b56f4baeb58f5093d092')
+
+prepare() {
+ cp -a "${srcdir}/${_module}-${pkgver}"{,-python2}
+}
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+
+ cd "${srcdir}/${_module}-${pkgver}-python2"
+ python2 setup.py build
+}
+
+package_python-mss() {
+ depends+=('python')
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
+
+package_python2-mss() {
+ depends+=('python2')
+ cd "${srcdir}/${_module}-${pkgver}-python2"
+ python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}