summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-06-06 11:14:33 +0100
committerGrey Christoforo2019-06-06 11:14:33 +0100
commite5e85a640f6acef1d2160d628159f0e7c669736b (patch)
treeb478157d218eaffae139375bf9773816a1acd9e9
parent96ba6dea115a6c340fdd4c0fed218128d4f23ab8 (diff)
downloadaur-e5e85a640f6acef1d2160d628159f0e7c669736b.tar.gz
drop python2, bump version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD47
2 files changed, 23 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5eec998df76..0540d9fc5a50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,14 @@
pkgbase = python-mss
- pkgdesc = An ultra fast cross-platform multiple screenshots module in pure python using ctypes.
- pkgver = 3.3.2
+ pkgdesc = An ultra fast cross-platform multiple screenshots module in pure Python using ctypes
+ pkgver = 4.0.3
pkgrel = 1
- url = https://github.com/BoboTiG/python-mss
+ url = https://github.com/BoboTiG/python-mss#python-mss
arch = any
license = MIT
makedepends = python-setuptools
- makedepends = python2-setuptools
- source = https://files.pythonhosted.org/packages/source/m/mss/mss-3.3.2.tar.gz
- md5sums = e9bc7dbd2551b56f4baeb58f5093d092
-
-pkgname = python-mss
depends = python
+ source = https://github.com/BoboTiG/python-mss/archive/v4.0.3.tar.gz
+ sha256sums = 4186dabd3afa21bf258cdcc9d10f66ccc6ec422bbbc4e3e563e34fcbcca59568
-pkgname = python2-mss
- depends = python2
+pkgname = python-mss
diff --git a/PKGBUILD b/PKGBUILD
index 6038439a0f16..add613cc0568 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,26 @@
-# Maintainer: Grey Christoforo <first name at last name dot net>
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
-pkgbase=python-mss
-pkgname=('python-mss' 'python2-mss')
-_module='mss'
-pkgver=3.3.2
+pkgname=python-mss
+pkgver=4.0.3
pkgrel=1
-pkgdesc="An ultra fast cross-platform multiple screenshots module in pure python using ctypes."
-url="https://github.com/BoboTiG/python-mss"
-depends=()
-makedepends=('python-setuptools' 'python2-setuptools')
-license=('MIT')
+pkgdesc="An ultra fast cross-platform multiple screenshots module in pure Python using ctypes"
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/m/mss/mss-${pkgver}.tar.gz")
-md5sums=('e9bc7dbd2551b56f4baeb58f5093d092')
-
-prepare() {
- cp -a "${srcdir}/${_module}-${pkgver}"{,-python2}
-}
+url=https://github.com/BoboTiG/python-mss#python-mss
+license=('MIT')
+depends=(python)
+makedepends=(python-setuptools)
+source=(https://github.com/BoboTiG/python-mss/archive/v${pkgver}.tar.gz)
+sha256sums=('4186dabd3afa21bf258cdcc9d10f66ccc6ec422bbbc4e3e563e34fcbcca59568')
build() {
- cd "${srcdir}/${_module}-${pkgver}"
- python setup.py build
-
- cd "${srcdir}/${_module}-${pkgver}-python2"
- python2 setup.py build
+ cd "$srcdir/python-mss-$pkgver"
+ python setup.py build
}
-package_python-mss() {
- depends+=('python')
- cd "${srcdir}/${_module}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
-}
-package_python2-mss() {
- depends+=('python2')
- cd "${srcdir}/${_module}-${pkgver}-python2"
- python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+package(){
+ cd "$srcdir/python-mss-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}
+
+# vim:ts=2:sw=2:et: