summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Langlois2022-04-29 10:56:05 -0700
committerEric Langlois2022-04-29 10:56:05 -0700
commit5ac505877dbf07fe8d18baaa6b864220e38ce541 (patch)
tree50017bca2662d7e5f67bfaf011a27963a01a5e60
parent0056383f149ae3f9232f1d2dbf2bfbf8a4502f8b (diff)
downloadaur-5ac505877dbf07fe8d18baaa6b864220e38ce541.tar.gz
upgpkg: python-mujoco-py 2.1.2.14-3
Patch to work with mujoco 2.1.5
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
-rw-r--r--mujoco-py.patch2
3 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b86155977383..2d67a752da03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-mujoco-py
pkgdesc = Python interface to the MuJoCo physics engine
pkgver = 2.1.2.14
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/openai/mujoco-py
arch = x86_64
license = MIT
@@ -9,7 +9,6 @@ pkgbase = python-mujoco-py
makedepends = patchelf
makedepends = python-setuptools
depends = cython
- depends = glew
depends = libgl
depends = mesa
depends = mujoco
diff --git a/PKGBUILD b/PKGBUILD
index b91a8d7ff9c2..fa3b7c7d5fe7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,13 @@
pkgname=python-mujoco-py
_name=${pkgname#python-}
pkgver=2.1.2.14
-pkgrel=2
+pkgrel=3
pkgdesc="Python interface to the MuJoCo physics engine"
arch=('x86_64')
url="https://github.com/openai/mujoco-py"
license=('MIT' 'custom')
depends=(
'cython'
- 'glew'
'libgl'
'mesa'
'mujoco'
@@ -32,6 +31,9 @@ sha256sums=('eb5b14485acf80a3cf8c15f4b080c6a28a9f79e68869aa696d16cbd51ea7706f'
prepare() {
cd "$_name-$pkgver"
patch -p1 -i "$srcdir/$_name.patch"
+ sed -i'' 's/glewInitialized/glInitialized/g' \
+ 'mujoco_py/pxd/mjrender.pxd' \
+ 'mujoco_py/generated/wrappers.pxi'
}
build() {
diff --git a/mujoco-py.patch b/mujoco-py.patch
index 2ab1c14296b7..ce4cd6c68a82 100644
--- a/mujoco-py.patch
+++ b/mujoco-py.patch
@@ -116,7 +116,7 @@ diff '--color=auto' --unified --recursive --text mujoco-py-2.1.2.14.orig/mujoco_
- mujoco_path = join(expanduser('~'), '.mujoco', 'mujoco210')
+ mujoco_path = join(expanduser('~'), '.mujoco', 'mujoco')
+ if not exists(mujoco_path):
-+ mujoco_path = "/opt/mujoco"
++ mujoco_path = "/usr/include/mujoco"
# We get lots of github issues that seem to be missing these
# so check that mujoco is really there and raise errors if not.