summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbitwave2018-07-31 12:16:53 +0200
committerbitwave2018-07-31 12:18:14 +0200
commit3d6645895769804641327c022548a65a6302414b (patch)
treefa000c2e906db07b266ede019888c18741dbacfd
downloadaur-3d6645895769804641327c022548a65a6302414b.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f70e14b85241
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Jul 31 10:18:09 UTC 2018
+pkgbase = python-mupdf
+ pkgdesc = Python bindings for the PDF rendering library MuPDF
+ pkgver = 1.13.15
+ pkgrel = 1
+ url = https://github.com/rk700/PyMuPDF
+ arch = any
+ license = AGPL
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/p/pymupdf/PyMuPDF-1.13.15.tar.gz
+ md5sums = 822bdf668992b11551b55ff3f5a72f0b
+
+pkgname = python-mupdf
+ depends = python
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..631602bbc501
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgbase=('python-mupdf')
+pkgname=('python-mupdf')
+_module='PyMuPDF'
+pkgver='1.13.15'
+pkgrel=1
+pkgdesc="Python bindings for the PDF rendering library MuPDF"
+url="https://github.com/rk700/PyMuPDF"
+depends=('python')
+makedepends=('python-setuptools')
+license=('AGPL')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/p/pymupdf/PyMuPDF-${pkgver}.tar.gz")
+md5sums=('822bdf668992b11551b55ff3f5a72f0b')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}