summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2022-11-05 18:53:50 +0100
committerMartino Pilia2022-11-05 18:53:50 +0100
commita2795a5e8227f65fbf0b0d21294d377200a9e115 (patch)
tree9f8d43e3386c1bde3388c5a2dd6ec151653fa9b2
parent4f941effa7fc0ec6a15909ec32db9297928abfe7 (diff)
downloadaur-python-music21.tar.gz
Version 8.1.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
2 files changed, 23 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 346ecd3724b4..c63237c6dda9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,18 @@
pkgbase = python-music21
pkgdesc = A toolkit for computer-aided musical analysis
- pkgver = 7.3.0
+ pkgver = 8.1.0
pkgrel = 1
url = http://web.mit.edu/music21
arch = any
license = BSD
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-hatchling
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python-chardet
depends = python-joblib
depends = python-more-itertools
+ depends = python-requests
depends = python-webcolors
optdepends = lilypond: PDF or PNG output with music21.converter
optdepends = python-jsonpickle: pickle and unpickle objects with music21.freezeThaw
@@ -17,7 +21,7 @@ pkgbase = python-music21
optdepends = python-pyaudio: allows recording with music21.audioSearch
optdepends = python-pygame: allows realtime MIDI performance with music21.midi
optdepends = python-scipy: faster FFT for music21.audioSearch
- source = https://github.com/cuthbertLab/music21/archive/v7.3.0.tar.gz
- sha256sums = a2cfd7648339bf039da4a2569882e6cd43e4af6c91d3858d9d4909b702a1e53d
+ source = https://github.com/cuthbertLab/music21/archive/v8.1.0.tar.gz
+ sha256sums = 0fd00078fd9bfcc4f0c6e36d44fd6e5bb5b8506c6acba3796941b568a2cf64ad
pkgname = python-music21
diff --git a/PKGBUILD b/PKGBUILD
index 29ded4b51db7..75b3264b5ddc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Martino Pilia <martino.pilia@gmail.com>
_pkgname=music21
pkgname=python-$_pkgname
-pkgver=7.3.0
+pkgver=8.1.0
pkgrel=1
pkgdesc="A toolkit for computer-aided musical analysis"
arch=('any')
@@ -11,6 +11,7 @@ depends=(
'python-chardet'
'python-joblib'
'python-more-itertools'
+ 'python-requests'
'python-webcolors'
)
optdepends=(
@@ -22,9 +23,19 @@ optdepends=(
'python-pygame: allows realtime MIDI performance with music21.midi'
'python-scipy: faster FFT for music21.audioSearch'
)
-makedepends=('python-setuptools')
+makedepends=(
+ 'python-build'
+ 'python-hatchling'
+ 'python-installer'
+ 'python-wheel'
+)
source=("https://github.com/cuthbertLab/music21/archive/v${pkgver}.tar.gz")
-sha256sums=('a2cfd7648339bf039da4a2569882e6cd43e4af6c91d3858d9d4909b702a1e53d')
+sha256sums=('0fd00078fd9bfcc4f0c6e36d44fd6e5bb5b8506c6acba3796941b568a2cf64ad')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
cd "$srcdir/$_pkgname-$pkgver"
@@ -33,5 +44,5 @@ package() {
"${srcdir}/$_pkgname-$pkgver/LICENSE" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- python setup.py install --optimize=1 --root="$pkgdir"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}