summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2020-03-05 00:21:43 +0100
committerMartino Pilia2020-03-05 00:21:43 +0100
commit2b3119daa427d0110dfa6dbc00698aa1b307252d (patch)
tree4c36f57156050dc8cc7789182181a4e0ad07636a
parent39f029fa966a223408c429a3a8f4aa796187b345 (diff)
downloadaur-2b3119daa427d0110dfa6dbc00698aa1b307252d.tar.gz
Add runtime dependencies
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 28 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe1d9cf32d4e..ddf94d5c4f2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,22 @@
pkgbase = python-music21
pkgdesc = A toolkit for computer-aided musical analysis
pkgver = 5.7.2
- pkgrel = 1
+ pkgrel = 2
url = http://web.mit.edu/music21
arch = any
license = BSD
makedepends = python-setuptools
- depends = python
+ depends = python-chardet
+ depends = python-joblib
+ depends = python-more-itertools
+ depends = python-webcolors
+ optdepends = lilypond: PDF or PNG output with music21.converter
+ optdepends = python-jsonpickle: pickle and unpickle objects with music21.freezeThaw
optdepends = python-matplotlib: graphing support
- optdepends = python-scipy: scientific extension to Python
- optdepends = python-pyaudio: allows for recording within Python
- optdepends = python-pygame: allows for realtime MIDI performance
- optdepends = python-pillow: resources for transforming and editing graphics files
- optdepends = lilypond: automatically generate PDF or PNG files
+ optdepends = python-pillow: high quality output from LilyPond
+ optdepends = python-pyaudio: allows recording with music21.audioSearch
+ optdepends = python-pygame: allows realtime MIDI performance with music21.midi
+ optdepends = python-scipy: faster FFT for music21.audioSearch
source = https://github.com/cuthbertLab/music21/archive/v5.7.2.tar.gz
sha256sums = ba15f82f3a543e538d369b54ef431905f5a446787779529a4e0ba65e60d52159
diff --git a/PKGBUILD b/PKGBUILD
index 842a24f90760..31794c40215e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,32 @@
_pkgname=music21
pkgname=python-$_pkgname
pkgver=5.7.2
-pkgrel=1
+pkgrel=2
pkgdesc="A toolkit for computer-aided musical analysis"
arch=('any')
url="http://web.mit.edu/music21"
license=('BSD')
-depends=('python')
-optdepends=('python-matplotlib: graphing support'
- 'python-scipy: scientific extension to Python'
- 'python-pyaudio: allows for recording within Python'
- 'python-pygame: allows for realtime MIDI performance'
- 'python-pillow: resources for transforming and editing graphics files'
- 'lilypond: automatically generate PDF or PNG files')
+depends=(
+ 'python-chardet'
+ 'python-joblib'
+ 'python-more-itertools'
+ 'python-webcolors'
+)
+optdepends=(
+ 'lilypond: PDF or PNG output with music21.converter'
+ 'python-jsonpickle: pickle and unpickle objects with music21.freezeThaw'
+ 'python-matplotlib: graphing support'
+ 'python-pillow: high quality output from LilyPond'
+ 'python-pyaudio: allows recording with music21.audioSearch'
+ 'python-pygame: allows realtime MIDI performance with music21.midi'
+ 'python-scipy: faster FFT for music21.audioSearch'
+)
makedepends=('python-setuptools')
source=("https://github.com/cuthbertLab/music21/archive/v${pkgver}.tar.gz")
sha256sums=('ba15f82f3a543e538d369b54ef431905f5a446787779529a4e0ba65e60d52159')
package() {
- cd "$srcdir/$_pkgname-$pkgver" || exit 1
+ cd "$srcdir/$_pkgname-$pkgver"
install -D -m644 \
"${srcdir}/$_pkgname-$pkgver/LICENSE" \