summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Steinke2015-09-09 05:44:37 +0200
committerRasmus Steinke2015-09-09 05:44:37 +0200
commit5535cac88cd5afcad4bce7d5b41106020ed0293f (patch)
tree80e128c4e42b44725187d3cf7b396115133f7713
downloadaur-5535cac88cd5afcad4bce7d5b41106020ed0293f.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a64005907de2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-musicpd
+ pkgdesc = An MPD (Music Player Daemon) client library written in pure Python.
+ pkgver = 0.4.2
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/python-musicpd
+ arch = any
+ license = GPL
+ makedepends = make
+ depends = python
+ source = https://pypi.python.org/packages/source/p/python-musicpd/python-musicpd-0.4.2.tar.gz
+ md5sums = acdaa0d479959a6af6224ce215d17577
+
+pkgname = python-musicpd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01a2ab3be78a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Rasmus Steinke <rasi at xssn dot at>
+
+pkgname=python-musicpd
+pkgver=0.4.2
+pkgrel=1
+pkgdesc="An MPD (Music Player Daemon) client library written in pure Python."
+arch=('any')
+url="https://pypi.python.org/pypi/python-musicpd"
+license=('GPL')
+depends=('python')
+makedepends=('make')
+source=("https://pypi.python.org/packages/source/p/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums=('acdaa0d479959a6af6224ce215d17577')