summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormaz-12015-10-27 10:09:36 +0800
committermaz-12015-10-27 10:09:36 +0800
commit8f4bf0112b9aeeafc006237f7bcfd8e38300b09d (patch)
tree827b357b0cf2985fa4f66cb11a0671702f94d65f
downloadaur-8f4bf0112b9aeeafc006237f7bcfd8e38300b09d.tar.gz
init
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f60b6a0c271c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-mutagenx
+ pkgdesc = read and write audio tags for many formats in Python 3
+ pkgver = 1.24
+ pkgrel = 1
+ url = https://github.com/LordSputnik/mutagen/
+ arch = any
+ license = GPL2
+ depends = python
+ conflicts = mutagen
+ source = https://pypi.python.org/packages/source/m/mutagenx/mutagenx-1.24.tar.gz
+ md5sums = e6815203bfc4b8cd46e7405525a28f14
+
+pkgname = python-mutagenx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb8a6766dbc0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Alfred Krohmer <devkid@devkid.net>
+pkgname=python-mutagenx
+pkgver=1.24
+pkgrel=1
+pkgdesc="read and write audio tags for many formats in Python 3"
+url="https://github.com/LordSputnik/mutagen/"
+depends=('python')
+conflicts=('mutagen')
+license=('GPL2')
+arch=('any')
+source=("https://pypi.python.org/packages/source/m/mutagenx/mutagenx-$pkgver.tar.gz")
+md5sums=('e6815203bfc4b8cd46e7405525a28f14')
+
+build() {
+ cd $srcdir/mutagenx-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/mutagenx-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+}