summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-05-02 00:53:07 +0300
committerCaleb Maclennan2020-05-02 00:53:07 +0300
commit3e5da655f1f8c0a7da60cdc66300fe2aecb332f6 (patch)
treed7951abb9fe5ef49de7b41251019bbb1c05fdb0e
parent43569c3962d44515886cbb50de798c7377c64d23 (diff)
downloadaur-3e5da655f1f8c0a7da60cdc66300fe2aecb332f6.tar.gz
upgpkg: python-mutatormath 3.0.1-1
upstream release
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD34
2 files changed, 24 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9959a6713deb..fccbd8c0c95d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-mutatormath
- pkgdesc = A library for the calculation of piecewise linear interpolations in n-dimensions with any number of masters.
- pkgver = 2.1.2
+ pkgdesc = Piecewise linear interpolation in multiple dimensions with multiple, arbitrarily placed, masters
+ pkgver = 3.0.1
pkgrel = 1
url = https://github.com/LettError/MutatorMath
arch = any
@@ -10,9 +10,8 @@ pkgbase = python-mutatormath
depends = python-fonttools
depends = python-defcon
depends = python-fontmath
- options = !emptydirs
- source = https://pypi.org/packages/source/M/MutatorMath/MutatorMath-2.1.2.zip
- sha256sums = 6930f966a07a7459bcdb15b36dbcb615a791853d79965897cedb1047d5beeecb
+ source = https://files.pythonhosted.org/packages/source/M/MutatorMath/MutatorMath-3.0.1.zip
+ sha256sums = 8127c1ffad1646f11a953752296c43f5d88cbd5293fff03f093d916b0bc13864
pkgname = python-mutatormath
diff --git a/PKGBUILD b/PKGBUILD
index 89f1b8f1f561..ae12785e2158 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,32 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
-# Ex-Maintainer: William Turner <willtur.will@gmail.com>
-pkgname='python-mutatormath'
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Contributor: William Turner <willtur.will@gmail.com>
+
+pkgname=python-mutatormath
_pkgname=MutatorMath
-pkgver=2.1.2
+pkgver=3.0.1
pkgrel=1
-pkgdesc='A library for the calculation of piecewise linear interpolations in n-dimensions with any number of masters.'
+pkgdesc='Piecewise linear interpolation in multiple dimensions with multiple, arbitrarily placed, masters'
arch=('any')
url='https://github.com/LettError/MutatorMath'
license=('BSD')
depends=('python' 'python-fonttools' 'python-defcon' 'python-fontmath')
makedepends=('python-setuptools')
-options=(!emptydirs)
-source=("https://pypi.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.zip")
-sha256sums=('6930f966a07a7459bcdb15b36dbcb615a791853d79965897cedb1047d5beeecb')
-
-package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- python setup.py install --root=$pkgdir ||return 1
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-}
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.zip")
+sha256sums=('8127c1ffad1646f11a953752296c43f5d88cbd5293fff03f093d916b0bc13864')
check() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "$_pkgname-$pkgver"
python setup.py test
}
+
+build() {
+ cd "$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}