summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-08-19 12:49:47 -0400
committerGuillaume Horel2019-08-19 12:49:47 -0400
commit43569c3962d44515886cbb50de798c7377c64d23 (patch)
treefdb16b1b0aad0ec0dede22588c5e0ee66dfcba6c
parent3f23340646860919645aa997e5b2de72c51b9ad2 (diff)
downloadaur-43569c3962d44515886cbb50de798c7377c64d23.tar.gz
version bump
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD56
2 files changed, 19 insertions, 66 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9a9afc35f9e..9959a6713deb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,39 +1,18 @@
pkgbase = python-mutatormath
pkgdesc = A library for the calculation of piecewise linear interpolations in n-dimensions with any number of masters.
- pkgver = 2.1.1
+ pkgver = 2.1.2
pkgrel = 1
url = https://github.com/LettError/MutatorMath
arch = any
license = BSD
- makedepends = python-pip
- makedepends = python2-pip
+ makedepends = python-setuptools
depends = python
depends = python-fonttools
- depends = python-ufolib
depends = python-defcon
depends = python-fontmath
- depends = python2
- depends = python2-fonttools
- depends = python2-ufolib
- depends = python2-defcon
- depends = python2-fontmath
options = !emptydirs
- source = https://files.pythonhosted.org/packages/py2.py3/M/MutatorMath/MutatorMath-2.1.1-py2.py3-none-any.whl
- sha256sums = e6da8ae2a7008085ee0bac6d62737d37b90ce4a883d89a0f3d5c19dd350b0538
+ source = https://pypi.org/packages/source/M/MutatorMath/MutatorMath-2.1.2.zip
+ sha256sums = 6930f966a07a7459bcdb15b36dbcb615a791853d79965897cedb1047d5beeecb
pkgname = python-mutatormath
- depends = python
- depends = python-fonttools
- depends = python-ufolib
- depends = python-defcon
- depends = python-fontmath
- provides = python-mutatormath
-
-pkgname = python2-mutatormath
- depends = python2
- depends = python2-fonttools
- depends = python2-ufolib
- depends = python2-defcon
- depends = python2-fontmath
- provides = python2-mutatormath
diff --git a/PKGBUILD b/PKGBUILD
index 037f056fda4d..89f1b8f1f561 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,26 @@
-# Maintainer: William Turner <willtur.will@gmail.com>
-pkgbase=python-mutatormath
-pkgname=(python-mutatormath python2-mutatormath)
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+# Ex-Maintainer: William Turner <willtur.will@gmail.com>
+pkgname='python-mutatormath'
_pkgname=MutatorMath
-pkgver=2.1.1
+pkgver=2.1.2
pkgrel=1
pkgdesc='A library for the calculation of piecewise linear interpolations in n-dimensions with any number of masters.'
arch=('any')
url='https://github.com/LettError/MutatorMath'
license=('BSD')
-depends=('python' 'python-fonttools' 'python-ufolib' 'python-defcon' 'python-fontmath'
- 'python2' 'python2-fonttools' 'python2-ufolib' 'python2-defcon' 'python2-fontmath')
-makedepends=('python-pip' 'python2-pip')
+depends=('python' 'python-fonttools' 'python-defcon' 'python-fontmath')
+makedepends=('python-setuptools')
options=(!emptydirs)
-source=("https://files.pythonhosted.org/packages/py2.py3/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}-py2.py3-none-any.whl")
-sha256sums=('e6da8ae2a7008085ee0bac6d62737d37b90ce4a883d89a0f3d5c19dd350b0538')
+source=("https://pypi.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.zip")
+sha256sums=('6930f966a07a7459bcdb15b36dbcb615a791853d79965897cedb1047d5beeecb')
-package_python-mutatormath() {
- depends=('python' 'python-fonttools' 'python-ufolib' 'python-defcon' 'python-fontmath')
- provides=('python-mutatormath')
-
- cd "${srcdir}"
-
- # install the wheel
- PIP_CONFIG_FILE=/dev/null pip install \
- --isolated \
- --root="${pkgdir}" \
- --ignore-installed \
- --no-deps \
- ${_pkgname}-${pkgver}-py2.py3-none-any.whl
-
- # compile to pyo
- python -O -m compileall "${pkgdir}"
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root=$pkgdir ||return 1
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-package_python2-mutatormath() {
- depends=('python2' 'python2-fonttools' 'python2-ufolib' 'python2-defcon' 'python2-fontmath')
- provides=('python2-mutatormath')
-
- cd "${srcdir}"
-
- # install the wheel
- PIP_CONFIG_FILE=/dev/null pip2 install \
- --isolated \
- --root="${pkgdir}" \
- --ignore-installed \
- --no-deps \
- ${_pkgname}-${pkgver}-py2.py3-none-any.whl
-
- # compile to pyo
- python2 -O -m compileall "${pkgdir}"
+check() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py test
}